I overwrote a native latex command and cannot access the Obsidian latex library to reset it

Steps to reproduce

  1. type latex string:
    $$\def\text{test text}$$

  2. the native \text{} command now becomes a macro that inserts the string testtext

Expected result

Latex shouldn’t overwrite native commands, but something with Obsidian’s implementation might be allowing \def to overwrite \text{}

Actual result

\text{} native command is completely overwritten by the \def macro definition in the brackets.

Environment

  • Operating system: MacOS 10.15.7
  • Debug info:
    SYSTEM INFO:
    Obsidian version: v0.14.6
    Installer version: v0.13.23
    Operating system: Darwin Kernel Version 19.6.0: Thu Jan 13 01:26:33 PST 2022; root:xnu-6153.141.51~3/RELEASE_X86_64 19.6.0
    Login status: logged in
    Catalyst license: none
    Insider build toggle: off
    Live preview: on
    Legacy editor: off
    Base theme: dark
    Community theme: Blue Topaz
    Snippets enabled: 1
    Safe mode: off
    Plugins installed: 40
    Plugins enabled: 36
    1: Annotator
    2: Advanced Tables
    3: Calendar
    4: Periodic Notes
    5: Rollover Daily Todos
    6: Templater
    7: TimeStamper
    8: Outliner
    9: Kanban
    10: Mind Map
    11: Day Planner
    12: Meld Calc
    13: Obsidian Tabs
    14: cMenu
    15: Better PDF Plugin
    16: LanguageTool Integration
    17: Pandoc Plugin
    18: Hotkeys++
    19: TagFolder
    20: Juggl
    21: Tag Wrangler
    22: Excalidraw
    23: Admonition
    24: Banners
    25: Paste URL into selection
    26: Dataview
    27: Tracker
    28: Text Snippets
    29: Simple Embeds
    30: Desmos
    31: Obsidian Charts
    32: Natural Language Dates
    33: Extract PDF Annotations
    34: Quick Latex for Obsidian
    35: Latex Environments
    36: Extended MathJax

RECOMMENDATIONS:
Custom theme: for cosmetic issues, please first try updating your theme to latest. If still not fixed, please try to make the issue happen in the help vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the help vault or disable community plugins.


Additional information

example of \text{help} not returning a text string “help”

Does it get fixed when you restart obsidian?

It didn’t fix on restart, but I ended up deleting and reinstalling and that seemed to fix it.