I love the new link fuzzy searching

I think before when you were linking between notes, it would only show links which had titles in the order of what you were typing.

For example, typing “[[switching hotkey” would completely ignore a note titled “hotkey switching” in its suggestions.

I noticed today it now shows both in the search results, which makes linking so much better.

Thank you for adding this!

we have not added this.

Have you tried this? It’s working on my end.

when you get to “hotkey s”, it won’t match anymore.

What’s this then?

I can’t reproduce this.

Are you on version 0.13.19?

Post a screen recording of this happening in the help vault.

I thought I could reproduce this as [[repetition spaced]] matched my file named spaced repetition index. But then I realised it was also matching on the folder name (which was spaced repetition) so “repetition” matched the file and “spaced” matched the folder. [[index repetition]] doesn’t match.

This is not exactly a problem, it’s a good thing, though I was told to post this here.


Here’s a clip of me using fuzzy link search to find both notes.

Using Obsidian v0.13.19.

Please reinstate my post to the Meta forum rather than “resolved help”.

I think we are misunderstanding each other. I didn’t tell you to open a new post in the help section. I am telling you to do a screen recording while using help vault (open with bottom right question mark).

I am 100% sure we did not add this. So this is not part of obsidian core behavior.

Sorry, definitely did misunderstand you, was about to post though you got there first :sweat_smile:

I tried to reproduce this in the Help vault and wasn’t able to, so maybe this is something one of my plug-ins is serendipitously doing.

It’s weird though as I haven’t intentionally installed any plug-ins that do this.

@WhiteNoise I just tried disabling all of my plug-ins by switching to Safe mode, restarting, setting to default theme, disabling any CSS snippets, and it still lets me use fuzzy link searching.

I don’t really know what else to rule out that could cause this useful behaviour, though I’m happy it’s happening anyway. :sweat_smile: