I have lost all of my notes Macbook Air M1

What I’m trying to do

I’m having an issue and I’m sure there must be a solution I just can’t think of, in any case, its entirely my fault and I just want to recover the files or be able to use obsidian properly again.

For context, I have a Macbook Air M1 (13.3.1) and I have all of my worldbuilding for a book in obsidian.

I noticed that my Mac didn’t have any way to save files locally, so I copied everything from my desktop and documents files in iCloud to a local folder and turned off storage optimization for documents and desktop, but it seems like my obsidian files didn’t copy over and I’m not sure how to access them.

I do still have obsidian open from when I last worked on it and I can see the graph view, but all of the notes are blank and I get this error message for every note:

"Failed to load “Note Name.md”. ENOENT: no such file or directory, open ‘Users/darrianthompson/Desktop/Eirda/Note Name.md’

Things I have tried

I’ve tried searching but I’m honestly not sure what to search for because this is so specific and I don’t currently have any plugins or anything. I’m not very tech savvy so I don’t want to do anything that will ruin it further.

Most of my work was not available in the file recovery, However, I noticed if I click on a note and hit Command, I can see the full note in a preview, so I’ve been able to copy all of my work into a word document over the last few hours.

I’m just wondering if there is a way to make it so I don’t have to copy it all back into obsidian, and if I do, will I be able to access it, because it doesn’t seem like It’s saving in a file that exists if that makes sense.


1 Like

First, I would check the trash folder for Mac via Finder. Type ‘.md’ in the search field to see if your notes are in trash. If so, select, R click and select move out of trash.

If that doesn’t work, press ‘Shift+Cmnd+.’ and see if there is a .Trash folder hidden in the folder for your obsidian vault. If so you can move all those notes out of the hidden trash folder and back into your root folder.

I recommend taking some screen shots of your obsidian vault and finder window with the issues you’re describing. This will help anyone else narrow down possibilities.

Thank you for taking the time to respond. There doesn’t appear to be anything in the trash. I can’t actually find any record that obsidian is even on my mac in finder aside from the app.

This is what it looks like inside

Have you searched that error message here? There are some threads about it, some marked as solved. I don’t know if any will help you.


Also, there should be copies in your general computer backups. (If you don’t have backups, make that your top priority after you solve this problem.)

Thank you! I have checked those posts but they all mention that pluggin’s are causing the issue and I don’t have any.

My backups were saved in iCloud which was wiped when I turned off the “optimize storage” button, so I can’t find anything related to obsidian on my computer, I’m not sure there is a way to change the save location or not but it’s not usable right now. The only thing I can think of it reinstaling it and starting over.

Also, it is seems like it is just this vault, my other vaults are working fine.

Anything recoverable from iCloud.com?

Recover files deleted from iCloud Drive or iWork apps

  1. In iCloud Drive on iCloud.com, click Recently Deleted in the sidebar.
  2. Click Recover All, or select each file you want to recover, then click Recover.

Just to let you know I had a very similar issue with OneDrive over the weekend. Link below. I also saw folder structure but no files/notes & I may have also seen flashes of previews. As we are on different clouds… Could this be a fault in the latest Obsidian version… 1.28 ?

Not sure how to log an issues & work prevents me getting more detailed but maybe we should both see if we can escalate is as a possible bug…

Can you access the markdown files from iCloud Drive on a browser?

EDIT: Sorry, just saw the same suggestion above

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.