I changed the system default PDF reader, but Obsidian still opens in the old default app

What I’m trying to do

I’m on Ubuntu. The default PDF reader was Document Viewer, but I changed it to Okular. When I right click on a PDF file in Obsidian and select “open in default app”, it still uses Document Viewer.

Things I have tried

I searched for “default app” “pdf” and a few other search options. I didn’t see anyone having this same issue.

I have tried locating PDF files in my Obsidian Vault using the Ubuntu file explorer and opening them by double clicking, to confirm that Okular is the system default.

I tried rebooting my system, but I still see the behavior described above.

Default app settings on Linux can be tricky, with multiple places to set them. I think this has been discussed before, but I don’t remember where or if a solution was found. It might be an issue with Electron (the Chromium-based framework Obsidian runs in).

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.