I can't put texts and titles inside my fist heading. HELP!

my obsidian was normal, out of nowhere it is not putting more texts inside the heading. I’ve even tried to create a vault from scratch, but still with the same error! Someone help me

edit mode:

view mode:

I think that you’re just unnecessarily indenting headings. Put the hashes (#) as the first characters of the line and it will be fine.

The following markdown text

# When i put a heading
## I can't create another heading, and the text stay like this
### I tried to create a new vault, but suddelny everyone had this configuracion

is rendered as you expect:


BUT, if you add indentation (tabs or spaces before the hashes), they are rendered as a codeblock.


Notice the vertical lines that appear on the left while editing. They show the indentation level for each line:



an example, I was making this note earlier today. (note in portuguese)
where I have a #heading and inside it I have two more ##headings.
and it was normal

but now I’m not able to put ne headings or text with (TAB)
It is automatically turning codeblocks

when I put the heading inside another heading it turns into codeblocks:

Another example:
view mode:

Edit mode:

The reason your first example works is because it’s part of a list.

As andrezgz said, if you have 4 or more spaces outside of a list, it will turn into a code block.

See Basic Syntax | Markdown Guide

I’ve found that having a line after a ## heading isn’t necessary, but it’s considered a good practice.

1 Like

Now I get it! thank you very much.
Before my obsidian was automatically configured for the command (ENTER)
generate a list.
But he wasn’t in that mode anymore.
Is there a way to leave it in a standard list format?
Thank you very much! they helped me a lot

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.