I can't edit the groups of my filters

First, search the help docs and this forum. Maybe your question has been answered! The debugging steps can help, too. Still stuck? Delete this line and proceed.

What is the bug:

I just can edit ou create a new group. When I click on de button New group nothing happens. If I insist after a several clicks a new group is created, but I can’t edit the name or color.

What I’m trying to do

I have been trying to edit the groups in the graph.json, but this is not practical at all, and sometimes the groups just reset.

Things I have tried

I have tried to reinstall obsidian, and create a new vault to transfer my files. But this doesn’t work.

Also, I have tried to don’t install my external plugins.

Information about my system:

Obsidian version 1.5.3

I have been using these plugins: colored-text, highlightr-plugin, obsidian-languagetool-plugin, obsidian-table-generator, obsidian-to-anki-plugin and table-editor-obsidian.

Here’s a link to a video showing the problem: https://youtu.be/2Oj-InfioXE

I have the same issue. Even if I manage to create a new group (after dozens of clicks) I can’t write anything there as the input window just “deselects”.

Same here. The input field always loose activity. Like I would have clicked out from it.

I have the same problem shown in the video.
I turned off Hardware acceleration (Appearance → Hardware acceleration) and despite the dire warning in red, the problem went away. I think you could enter the filters / groups you want and then reenable HA until this is addressed as a crappy workaround.

I updated my graphics driver and there was no change:
Report Date: Friday, 12 April 2024
Report Time [hh:mm:ss]: 04:10:11 PM
Operating System: Microsoft Windows 10 Pro 10.0.19045
IGCC Version: 1.100.5435.0
Language: en-US
Physical Memory: 15.69 GB
Current Resolution: 1920x1080

Processor: 11th Gen Intel(R) Core™ i7-1185G7 @ 3.00GHz
Processor Speed: 2995 MHz
GFX Driver Name: Intel® Iris® Xe Graphics
Shader Version: 5.1
OpenCL* Version: 3.0
Microsoft DirectX
Runtime Version: 12
Hardware-Supported Version: 12
Vendor ID: 8086
Device ID: 9A49
Device Revision: 01
GFX Driver Version: 31.0.101.5382
Dedicated RAM: 128 MB
Shared RAM: 8 GB
Max Supported Displays: 4
GFX Vulcan: 1.3.277
GFX GOP: 17.0.1053

I have been unable to reproduce this. Does this happen in the sandbox vault?

With Hardware Acceleration:

  • Original vault has the issue described above.
  • Sandbox opened via help pop-up does NOT have the same issue.
  • New vaults made without any plug-ins or settings copied do not have this issue right away.
  • I’ve made multiple vaults that have grown in size which were not copies of each other, and they seem to have the same problems after some size threshold, as near as I can tell.

One thing I noticed is the sandbox nodes are completely static once they arrange, where all of my nodes in other vaults seem to endlessly drift constantly.

In all of the other examples, they appear to always be moving, even a minute amount at “rest”. It’s like this movement keeps grabbing the cursor focus, where every time the node arrangement moves at all, it yanks the focus from only the Filter > Group section/fields. Made a video to show all this, attached.

I am going to look into the logs and console errors to see if I can recreate it or get a better lead than this, but hopefully this will help you dial into it faster than that. I have no idea when I’ll get time to do the log extras. IF you have a particular test or command you’d like me to run that you can provide instructions for, I’m happy to do that though.

Cheers!

I don’t have a problem even if the graph is still moving.

Close all your other vaults.
In your main vault, use default theme, enable restricted mode, close and and reopen obsidian?

Does it still happen?

What is the output of the command (ctrl-p) “show debug info”

What kind of mouse/input device do you use?

I’d guess recreating it requires a combination of the laptop (Intel) video card / driver for how Hardware Acceleration is being applied. This is a CPU-GPU combo or something like that, which is likely sus. I’ve updated the graphics driver to the latest from this month (which is what I was noting in my initial post).

I have a GeForce driver in my other laptop I’ve tested in that didn’t have this issue as well as my main gaming rig that has a stand-alone GeForce card and certainly doesn’t have this issue. Can’t say for sure unless we can confirm the driver / video cards in others who recreate above or elsewhere, of course.

I made an active expression for document.activeElement to see what takes focus using these instructions.

Input is the normal when clicking on the filter elements.
When the problem occurs, this is what shows as having the focus:
body.mod-windows.is-frameless.is-maximized.is-hidden-frameless.is-focused.obsidian-app.theme-light.show-inline-title.show-view-header

Same thing happens with Dark Mode enabled:
body.mod-windows.is-frameless.is-maximized.is-hidden-frameless.obsidian-app.show-inline-title.show-view-header.is-focused.theme-dark

I use a Logitech mouse, nothing super fancy and I’ve moved it between machines with and without this issue. I’m confident it isn’t a peripheral / mouse driver issue otherwise the Sandbox would have also had a problem on my side.

Based on what I know, I would guess that something in the MD files is doing something to the graph… but its not “broken”. The grabbing focus is “operating normally” despite it having that impact on the filter box via JS or CSS.

Debug Info:

SYSTEM INFO:
	Obsidian version: v1.5.12
	Installer version: v1.5.8
	Operating system: Windows 10 Pro 10.0.19045
	Login status: not logged in
	Insider build toggle: off
	Live preview: on
	Base theme: dark
	Community theme: none
	Snippets enabled: 0
	Restricted mode: on

RECOMMENDATIONS:
	none

The testing above is with Community Plugins disabled, fwiw.

Hello,

I seem to have the same issue. I am unable to select the field to create a group, as the cursor deselects automatically after my click.

What information can I provide to hope for a problem solving ?

This issue is occurring for me too and as far as I can tell it doesn’t look like there’s any work around. I did notice when I got an already established group deleted, I can’t add it back in. It’s like it just doesn’t want to add new ones or let me make changes. I’ve definitely tried all the things I can think of and any suggestions here. It renders a huge portion of what I need Obsidian for just completely useless.

I was never able to reproduce this. However, we recently discovered a problem in graph view that happens more frequently (but is not tied to) vault stored in external media with heavy filters.

We will fix that bug in version 1.7 (No ETAs). When you get version 1.7 let me know if it solves this problem too.

I have the feeling the two problems are a manifestation of the same issue.