I cannot type character ˜ in my words without it deleting everything else

Steps to reproduce

If I write any word that contains the character “˜”, it deletes whatever came before this character was used in the word, so for example, I’m trying to type in “Constituição”, as soon as I type ã, it deletes the rest of the word and leaves me with just “ão”, and seen as using words with ˜ is extremelly common in portuguese, this is kinda getting on my nerves. Also, this problem only shows up when I’m using a separate keyboard connected via bluetooth on my tablet. My software keyboard language is set to portuguese and I don’t have this problem in any other apps except for Obsidian. The word disappears usually right when I press which vocal will have the ˜ on top of it, cause if you try to use this symbol, you’ll notice that you have to click the key it is in and then the letter it’s gonna be on top, and only then everything will appear (ã, õ, etc). I don’t know if this helps, feel free send me any doubts you have.

Did you follow the troubleshooting guide? [Y/N]

yes, I've tried it.

Expected result

I'd like to be able to just type the word and not have it disappear before my eyes after I enter the ˜ key.

Actual result

The beginning of the word disappears, leaving me with just the ã or õ


Operating system: android 14 (samsung SM-X610)
Obsidian version: 1.5.12 (134)
API version: v1.5.12
Login status: logged in
Catalyst license: none
Live preview: on
Base theme: light
Community theme: none
Snippets enabled: 0
Restricted mode: on


Additional information


Hi there,

Are you using predictive text? I’m not sure because I don’t have Android, but this sounds very similar to this issue. I’d recommend reading these threads and seeing if any of the fixes or upgrades work for you:

On Samsung this is caused by Samsung keyboard predictive text function. Either disable it or use Gboard.

We are getting some external confirmation that this is indeed a Samsung problem and should addressed in One UI 5.1. Let us know if that’s true and what keyboard version you have.

1 Like

Can you kindly post a screen recording of this happening in a new vault?

@rigmarole Hello, tysm! I tried turning off predictive text and it seemed to have solved the issue, now I can type in peace.
and @WhiteNoise it won’t be necessary anymore, but thank you for being available.
Have a nice day both of you