I cannot go in Squashfs-root in Cent OS 8 to install and configure Obsidian. Squashfs-root is greyed out in nautilus

Things I have tried

I downloaded Obsidian-0.12.19.AppImage and gave it permissions to be able to extract it. Then I extracted it with:
./Obsidian-0.12.19.AppImage --appimage-extract

What I’m trying to do

I want to install and configure Obsidian in Cent OS 8. I extracted the file ./Obsidian-0.12.19.AppImage --appimage-extract and got the squashfs-root folder. Nonetheless I cannot go in this folder. The folder looks like greyed out in Nautilus.

sudo cd /home/$USER/Download/squashfs-root
cd /home/$USER/Download/squashfs-root

bash: cd: squashfs-root: Permission denied
Do you have any idea to overcome this?

That looks as if you extracted it as root.

What works for me is supplying the absolute path, then --appimage-extract

I’m not using Cent OS, though.

i just used another folder that i had been able to open once in another computer the first time I installed Obsidian. But now the problem i face is as follows:
I run
sudo bash -c '/home/$user/Downloads/squashfs-root/AppRun'
and I get this output:

/home/$USER/Downloads/squashfs-root/AppRun: line 43: /home/$USER/Downloads/squashfs-root/obsidian: Permission denied

I already gave running permissions to the file AppRun manually but to no avail.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.