I broke kepano's Movie Database script's properties

What I’m trying to do

I’ve been using kepano’s movie database quickadd solution for a couple of years.

I tried to make a simple change and move the tags into the YAML properties from the body of my template. And it broke.

Screenshot from 2024-05-24 20-25-27

Things I have tried

I tried setting the property types again - no luck.
I tried editing the properties in Obsidian - they’re uncklickable.
I tried editing the .md file directly with an external editor, and I honestly can’t understand what the issue is. E.g., I tried removing the spaces within the curly brackets - no change.

image

I’m kind of lost as to what could be causing this, as the only change I made was move the tags inside the properties.

Any help would be appreciated!

I don’t know exactly what’s going in here, but switch to Source mode to edit any templates.

Thanks, that makes troubleshooting easier!
Though I still can’t figure out the problem…

For starters I reckon you shouldn’t have the colon after the brace and quote characters. That is change the lines ending with }": to just }"

It would also be helpful if you listed any error messages from the Console pane in Developers tool.

I’m not sure what difference it made, but I worked through kepano’s original steps to create the template and simply copied the YAML frontmatter from the template in the guide. It fixed the problem.
Thank you to all who tried to help!