How to start text at newline after HTML table?

This is note render in edit mode:

This is note render in view mode:

The question is: how to avoid table floating behavior and start text at newline?

I don’t think that’s default theme behaviour, so you might look into your theme for how it handles tables.

Or you might consider just adding a newline after the table markup, as it seems to be missing, which we don’t know since you’ve not provided any markup for how you achieved this to happen.

Obsidian was installed recently and has default settings.

Every table in document is provided with newline after HTML tables.

There are one more example of this render behavior:


The problem appears only with tables that occupy the part of available space of page (‘Readable line length’ setting is enabled) and behave like floating images in text, as showed at image below:

UPD: (2.3 KB)

Oh, you’re using html markup for the table. That is possibly part of the explanation for this misbehaving, but it also provides a way to most likely resolve it.

Try adding either of these lines after the table markup:

<span style="clear: both" />
<br style="clear: both" />

It’s a little guesswork related to which CSS has caused it, but either one of those lines could work to clear the issue and start afresh on a new line with the next header.

1 Like

The last line works well, thank you!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.