How to remove the spell-check underline from linked page/headings when using # in links

What I’m trying to do

When I link to a page, and then to a heading, I use the hashtag symbol, as you do. However the spell-check function underlines the ‘word/hashtag/word’ combination as a mis-spellt word. Is there any way to remove this?

Heres what I mean. First image with cursor in the link, second when clicked outside the link:



Things I have tried

I added ‘asterisk#asterisk’ in the Custom Dictionary (in Win10 - User > AppData > Roaming > obsidian), the only thing I can think of, but it doesnt work :unamused:


Anyone have any suggestions? Many thanks :grinning:

Hi Everyone!

I’m bumping this up in the hopes that someone sees it :grin:

I remember this post. I have the same problem. I do nothing about it. I don’t want to add these ‘bad#words’ to my custom dictionary.

For the spellchecker ‘abc#def’ is one string which will invariably be missing from the dictionary sets.

Of course, I imagine some CSS can be used to target the spellchecker lines on these headings. Someone might chip in sooner or later.

Unfortunately there’s nothing there to target for the spell-check underline. It’s coming from CodeMirror.

If I dig up anything, I’ll report back.

You are right.
I admit my head was somewhere else when I entered the second post.
You can see that by the word used by me ‘heading’.

I’m not seeing any spellcheck underline for these:

Interesting [[heading-test1#h5 heading]]
Interesting [[Walks#Presentation]]

Not sure why it’s there.

You could also try using display text in the link.

Interesting [[Walks#Presentation|Presentation]]

Hi People, thanks for you feedback

Agreed, plus it’s just extra ‘time-wasting’ work :face_with_hand_over_mouth:

@ariehen sorry I don’t understand anything about CodeMirror

Yes, this is perhaps the easiest solution.

I was hoping there might be a simple fix such as * # * (without the spaces) in the custom dictionary that I hadn’t thought of

@ariehen Maybe Obsidian could build it in to a future update :smiley: :smiley:

Yes, I wonder why you’re not getting the underline in your links???

I believe where a number is involved, there is no underline, as in your first example. But in your second example you have no underline, whereas I would have.

Strange. Maybe it’s something in my vault, I’ll investigate, Thanks!

I played around and I’m happy to say I found the solution!

@ariehen strange how you don’t get them but I do?!?

The solution: I assumed the * would be a ‘wildcard’, like it is in search engines. However, it isn’t. I added a silly number of them (asterisks), and now the red underline is gone (waves goodbye)

Yeah, not sure. How do the links look in the Sandbox vault?

In any event, glad you found a workaround for now.

Err sorry, what is the ‘Sandbox’ vault and where do I find it?

Hmm, didn’t realise the sandbox vault was there :sleeping:

Anyhow, the red underline does not show up in the vault, I guess suggesting its some conflict in my vault, however I’ve solved it (or as you say found a workaround) so that’s the main thing TYVM :smile:

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.