How to Remove the Native Markdown Toolbar After Installing a Toolbar Plugin?

Hello Obsidian Community,

I recently installed a toolbar plugin that better suits my workflow, but now I find myself with both the native Markdown toolbar and the toolbar from the plugin.

Is there a way to disable or remove the native Markdown toolbar so that only the plugin toolbar is visible? I couldn’t find any specific settings for this in the Obsidian preferences, and I would like to avoid clutter on my screen.

Has anyone else experienced this? If so, how did you manage to resolve it? Any tips, tricks, or insights are welcome!

Thank you in advance for your help!

If you are referring to the toolbar in the bottom of your screenshot, that’s not native to Obsidian. I believe the bottom one is added by the plugin. They may have an option to turn it off in their settings.

I’ve never seen that bottom toolbar so it might be from an add-on. It was because i wanted one that I installed the same new plugin as you. I rather like it. But beware that some of the things it does are using html markup. You can see those in the settings page where they are marked as (html). The toolbar doesn’t always show up though and i have to use the status bar icon to re-enable it.

Thank you for pointing that out. You’re correct; the toolbar at the bottom is actually added by the plugin. After some trial and error, I was able to resolve the issue by disabling and then re-enabling the plugin. I’m not entirely sure why this worked, but it did!

I’ve also checked the settings and the forum thread, but neither provided a straightforward solution until I tried the disable/enable trick.

Thanks for your input! It’s much appreciated.

I’m glad to hear you’ve also found the toolbar plugin useful! Yes, you’re correct about some of the features using HTML markup. It’s a great point to highlight, especially for those who may be wondering why certain functionalities behave the way they do.

As for the issue of the toolbar not always showing up, I’ve encountered the same problem. Using the status bar icon to re-enable it has been my workaround as well. I’m not sure if this is a bug or intended behavior, but it’s good to have a way to bring it back when needed

Overall, the toolbar does add a layer of convenience, even if it has a couple of quirks.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.