How to reduce the space between lines in dataview table?

What I’m trying to do

I use in-line variables to create dataview tables. The issue is that the line space between bullet points is too big. It wasn’t like this before and I haven’t made any changes to the settings so I think there’s been changes in the plugin itself.

The title of the file is in date form (e.g., 2024-03-02)

Things I have tried

This is the dataview query:

table
p as Progress, n as Next, r as Read
from "40 research journal"
where file.name > (this.file.day - dur(1w)) and file.ctime > (this.file.day - dur(1w))
sort file.name DESC 
limit 100

I have this same exact problem. It started in the release prior to the current release. I posted a similar issue on the forum and never got a resolution. My partial resolution of the issue was to not use the - prior to each entry. It appears the bullet point for each item is the culprit. Looking forward to see if you get any responses to your post.

1 Like

I just experienced this myself when doing a list within a table cell. Not sure why, but it’s not extremely clean html rendered when we’ve got a block element like <ul> within a line element <span> within a cell element <td>.

With that being said though, I couldn’t find any straight clues in the CSS as to why there was this extra spacing in the lists. However, themes like Github theme and Minimal is capable of removing it, so it is doable, but I just don’t know where to do it.

1 Like

The best I can do for now is this:
‘Style Settings’ plugin > Minimal > Lists and Tasks > List item spacing > set to 0.00
Even so the line height between list items is quite large.

The other method I found is this:
‘Style Settings’ plugin > Minimal > Tables > Disable Line Wrap (Unselect)
After unselecting ‘Diable Line Wrap’ the space between the list items become much smaller and natural but I really need to line wrap my tables so this isn’t a solution for me either.

I’m using the Minimal theme. Please see the reply I left for @matraug
Couldn’t find a feasible solution though.