How to open pdfs within a note?

What I’m trying to do

I have some pdfs related to my job that I keep within the vault and i have some notes with a link to them. But if I click (within obsidian) either the pdf file inside the attachment folder of my vault of the note with a link to the pdf, the pdf Always remains tiny (the preview within the note), and thus unreadable.

I want to store and access a pdf within the vault. So that either I open the note, click on the preview and the actual pdf opens up or I can open the attachment folder and open the actual pdf somehow.

Or at least click the pdf within the vault and be redirected to the folder on my phone.

Otherwise it’s useless to have it in obsidian, if every time I have to open my file Explorer app and go look for that pdf manually.

Things I have tried

I have tried all pdf plugins.

Have you tried to simply embed the pdf?


This is not obsidian’s usual behavior - would you mind posting a screenshot and a source example of one of your notes that link to a pdf?

I tried, doesn’t work. The preview appears but it’s tiny and unreadable and if I click it it doesn’t open the actual pdf.

Done. Can’t zoom on the pdf, can’t open the actual pdf, can’t open the actual folder of the pdf.

This was strange, I’m experiencing the same on my Android running the Obsidian 1.4.3 (95). I know that I’ve embedded PDF’s on desktop, and been able to both zoom and go full screen, but I can’t remember doing that on mobile. So I’m not sure if it’s just not supported, or if this is to be considered a bug or not.

But I can indeed verify, that it doesn’t allow for going fullscreen out of the box on Android.

You can’t click on an embedded pdf to open it.

I actually meant a screenshot of a usual link to a pdf, not an embedded link - can you post a screenshot of the note’s editing view?

Plus some more information: where exactly are your pdfs stored, for example?

I know I’m not the OP, but I can provide a very similar test case. PDF stored in MaDo/pdf/rm2-MA.pdf (within the vault), and the link used is simply [[rm2-MA.pdf]], or for the embedded version: ![[rm2-MA.pdf]].

In the embedded version it does display, but no zoom nor option to go fullscreen. In the linked version, it opens internally in Obsidian, full width, but still no zoom options.

@holroy are you talking of the mobile or desktop version? I can’t test on mobile as I don’t use obsidian’s mobile version. On desktop, everything is working as expected: I can embed, I can open it, I can open it using the default app, I can zoom (in all cases).

Yet, as far as I understood, the initial problem was that the pdf couldn’t be opened at all…

The screendump from the OP showcases a mobile interface, and the quote above says “on my phone”, so I was referring to the mobile version, yes.

My desktop version does have zoom option, at least. Not a full screen option.

The pdf is inside the vault.

Even if I insert a simple link to the pdf, it doesn’t open the actual pdf, it opens a tiny preview of it still within an obsidian page.

Completely useless. I don’t request for the app to manage it 100% but at least there must be a way to make it so that I click the pdf in the note and it opens the actual file (with another app) to have a quick access to it.

So I think what the OP is saying is that their are controls in the Destkop version for the PDF to zoom the document per below:

But on the mobile version, in reading view, it only shows the back and forward controls per below:

I think he is asking is there a way to get a PDF to display better on the mobile side with an external app because the text can’t be zoomed.

Yes indeed.

Or at least a way to click the pdf and open it with the pdf app of your phone (if obsidian isn’t able to handle a pdf on the mobile version).

There must be a way. Doesn’t make sense for it to just display tiny unreadable pdfs.

But doesn’t it work, on mobile, when you just store them in a separate (non-vault) folder and create an external link to it?

Or, alternatively, leave them in your vault, right-click the wikilink and chose “open with default app”?

I tried to make a link to a pdf not in the vault. The result is the same, just a preview.

How can I right click the wikilink and choose “open with default app”?

By right-clicking the link and chosing “open with default app”… :wink:

If you’re on mobile, there should be a “Show context menu under cursor” button in the mobile toolbar, or maybe also something similar for reading view (maybe obsidian mobile users can help - I don’t use it myself).

Could you please show how your wikilinks to pdfs look like? (in editing, not reading view…)

This is how the link looks like in editing mode.

And these are the options that appear to me if I long-click the link trying to simulate a right click on mobile.

It should be “Share”, I think…

Awesome! It does open the pdf in the proper app. Thank you!

If the developers happen to read this discussion please consider fixing this issue. This workaround works but it’d be better to just click on the preview and have the pdf open in the proper app.

I’m sure most users put pdfs in their notes.

Newby here. I can confirm all the above in terms of handling pdf’s on mobile. One of my workarounds was to screenshot a pdf page on desktop and save as .jpg. Obsidian will then allow you to zoom the image on mobile. Not ideal but it works. I can also confirm the share suggestion works on mobile but heck, that is not intuative…!