How to move local files for a synced vault?

Hello, new user here,

So far loving things, but I have small issue.
I set up a vault locally, then decided to subscribe to “sync” and connected it to that vault.
Now I would like to move that vault to a new directory/hard drive. I get an error message when attempting to use the “move vault” dialogue.
image

Using Windows, iOS 14, iPad OS

Things I have tried

  1. Used the native “move vault” command from the vault switcher.

What I’m trying to do

Move the local files on my PC to a new directory for a vault I am syncing.

Seems like Obsidian is asking you to relaunch the app, to update to a newer version.

(if that screenshot is the message you are referring to)

So perhaps close and reopen Obsidian, then attempt your move.

No it was just to include the version and installer version.
I have since updated the app, and no dice. I will grab a screenshot of the error message as i’m sure that will be more helpful

1 Like

I believe I worked out a solution:

  1. Disconnect from synced vault (the cloud copy)
  2. Copy entire vault folder and contents to target location/directory (locally)
  3. Use the native vault-switcher to “open folder as vault” on the newly copied location
  4. Close the previously used vault and “remove from list”
  5. Use the sync settings to connect the “new” vault to the cloud sync
  6. Delete the old vault folder & contents
1 Like