How to get rid of the grey bar at the top of the screen?

Hi everyone,

Very excited about the new version and loving the stacked tabs option, which seems to be a good substitute for Andy mode so far.

As I’m doing all my navigating via keyboard shortcuts I have no use whatsoever for the chunky grey bar at the top of my screen (the one that displays buttons for bringing out the right and left sidebars, and for adding and managing tabs). Is there a way to make it go away?

Perhaps this? But if you would please show a screenshot, we can tell if there is an appearance bug. It shouldn’t be “chunky”.

Settings → Appearance → Show tab title bar

Thanks for your reply, rigmarole. I have successfully disabled the title bar, but there’s another bar left (see screen shot below).

Could you please post the results of “Show Debug Info”?

That looks like a tab you have open. Which is odd, because it also shows as “No file is open”.

I would love to see a screenshot of the chunky bar you removed.

Also in your screenshot, there is a button that is under the 3-colored buttons in the Mac Window. This isn’t correct. Due to all 3 of these things, I suspect you might have some themes or snippets enabled that are incompatible with the new version, which might be causing multiple issues.

This is what it should look like.


Thanks again. Yes, the button underneath the button is not as it should be.

I’ve stacked my tabs, which (I assumed) is why they don’t show in that bar. In stacked tabs mode, the title is displayed in a vertical bar to the left of each tab, making the top tab bar mostly useless, especially if (like me) you don’t use your mouse to navigate your vault.

The bar displayed in the above screenshot is the chunky bar I’m talking about. The (thinner) bar I already got rid of (by disabling it under Settings → Appearance) is the "tab title bar; here it is enabled to demonstrate the difference (see screenshot).

I’m not running any themes or snippets. Here’s a list of plugins I have enabled: Hider, Hover Editor, Outliner, Tasks. If I disable Hider, the expand button no longer clashes with the Mac buttons, but the chunky and (to me) completely useless bar persists.

Forgot about the debug info. Here it is:

Obsidian version: v1.0.0
Installer version: v0.15.9
Operating system: Darwin Kernel Version 21.6.0: Mon Aug 22 20:17:10 PDT 2022; root:xnu-8020.140.49~2/RELEASE_X86_64 21.6.0
Login status: not logged in
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 0
Restricted mode: off
Plugins installed: 15
Plugins enabled: 4
1: Outliner v3.0.0
2: Hotkeys++ v0.2.7
3: Tasks v1.15.1
4: Hover Editor v0.11.4

Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

I’ve solved it: just had to update the Hider plugin, then enable the (previously missing) option “hide tab bar”, and voilà. Sorry for taking up your time!