How To Get a Monospaced Font in Obsidian Excalidraw Plugin

What I’m trying to do

I want to get rid of the fancy font used for text in the Excalidraw plugin. I regard this font as ridiculous. I want monospaced text just like everywhere else in Obsidian.

Things I have tried

I downloaded a Cascadia font face which is supposed to be monospaced. I loaded the WOFF2 file into the vault, I set the Excalidraw plugin to use the Fourth Font, and selected the Cascadian font from the drop down. Nothing happened - I get the same curly text face in my drawing.

The Excalidraw plugin is utterly useless to me with this fancy “hand-drawn” text nonsense. There needs to be a simple way to disable that and use whatever font Obsidian uses by default for text. I don’t care about themes, I use the default theme.

Update: Well, this is interesting. I typed some text in a rectangle and got the ridiculous font. I then opened the drawing as markdown and inspected the text element. It turns out that the font selected was “1” - which is Virgil, the default plugin font. However, I have Cascadia set as the Fourth Font. When I changed the “1” to a “2”, guess what? It works! The text becomes monospaced.

So to me this looks like a bug in the plugin. Selecting the Fourth Font does nothing for new documents. More than ever, this plugin needs a proper font handler built in to it. I obviously can’t open as Markdown and change the font type manually for every bit of text in my drawings.

Looks like I’m stuck with Obsidian Canvas for now. It has its deficiencies, too. No obvious way to ungroup a group of elements, for one.

Hi @richardstevenhack,

I don’t quite understand your challenge here. Am I misunderstanding something, or are you not seeing the properties menu (you might have accidently switched to Zen mode. (right click on the canvas to turn zen mode off)

This is how you change font: demo.mp4 (450×350)

BTW - you don’t need to install Cascadia as that is the 2nd font (as you also discovered by default).

If you set up a template for Excalidraw you can default it to Cascadia or any other font.
Here are two videos explaining templates:

I understand you are struggling with basic features. I recommend watching some of the training videos that explain the plugin as it is super powerful. Here’s the full Catalogue of Videos

Finally, I recommend you raise issues and questions with plugins not in the forum but on GitHub. That is the right place to get help:

1 Like

" This is how you change font: demo.mp4 (450×350) "

In that font video, it shows clicking on a palette icon in the lower left corner. There is no such icon in my version of Excalidraw, I am on version 1.9.19.

I see that there is a new version 2.0.16 released. Upon installing that, I see that when I click on the text icon, there is now a popup menu that contains the options to adjust the font from hand-drawn to normal to code to local font.

That solves my problem. I am just starting to use Excalidraw on a very minimal basis, so I expect I’ll run into other problems later.

I would say that defaulting the text style to hand-drawn really isn’t a good idea. But perhaps that’s just me.