How to avoid pasting MS Word text as an image?

For a few weeks now, when I copy and paste text from MS Word to Obsidian, it is pasted as an image.

I have to “Paste and match style” to avoid this.

I have searched Obsidian Settings and the forum, but I can’t find a way to disable this feature.

thanks a lot

Does it happen in the sandbox vault?

Thank you for your reply.

No, it doesn’t happen in the sandox vault.

but in my vault, even in restricted mode, it happens

Could you put your vault in Restricted Mode and then restart Obsidian to ensure everything plugin-related is cleared out? (Maybe Restricted Mode already clears everything, I don’t know, but I know sometimes when disabling a single plugin it can leave things behind.)

I did it, rebooted my computer and restarted Obsidian. that doesn’t matter. it happens again and again

Strange.

Could you explain the problem more? I didn’t really understand what is happening. Are you pasting a selection from Word that includes an image? Are you only copying text and it when you paste it you get an embedded link to an image file? Or do you just mean the text is formatted when you paste it (with bold text, etc).

That’s it. I copy selected text in a MS Word document

and i paste it on a note in Obsidian (with a shortcut Cmd+V or Edit/Paste)

and that’s what i get:

Wow, that is very strange.

You could try looking thru your plugins to see if any of them do anything with the clipboard or pasting or Word, and if so uninstall it temporarily.

Or you could copy your vault to a new folder, delete its .obsidian directory, and add back your settings and plugins. I have heard of at least 1 case where this solved a mystery problem. (If I knew more about the contents of .obsidian I might suggest a more targeted action.)

I’m sorry both of those are not very quick. At the moment I don’t have any other ideas.

Thank you very much. I’ll try it tomorrow or friday and will tell you.

What installer version is Obsidian using?

1 Like

Hi all

@ eightning: it’s version 0.15.9
@ CawlinTeffid : i created a new vault and activated the same plugins. It’s OK now. i think you’re right. it must be something in the .obsidian folder. Didn’t deleted it. i’ll check it later. thank you very much for your help.

2 Likes