How do I turn off combining characters into symbols?

Things I have tried

The text in the screencap is <!-- 19 --> … if I open the file in Notepad, I see that it’s the closing of an HTML comment, but in Obsidian it looks like an arrow, even though it’s not an arrow… it’s VERY confusing, because comments end with 3 characters not 1


What I’m trying to do

I’m trying to get it to display what I type, instead of munging it into nonsense… but I can’t find a setting to turn that off

after I posted that, I went digging for something else & this issue resolved itself… turns out it’s the font, just changed it with (sub in your favorite font, of course)

:root {
    --default-font: "Noto Sans", "Droid Sans", sans-serif;

my “something else” was tables that don’t wrap… fixed that with (probably the first part is enough, but I also didn’t like the font being different for tables, and mono fonts are just too wide for notes anyway):

.markdown-source-view.mod-cm6 .cm-line.HyperMD-table-row {
    min-width: 0;
    max-width: 100%;

.cm-s-obsidian .HyperMD-table-row {
    font-family: "Noto Sans", "Droid Sans", sans-serif !important;

For reference, it’s also possible to use CSS to disable that feature of the default font.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.