How do I find the root directory of my theme?

What I’m trying to do

I’m trying to follow the directions here to release an update to my theme. Don’t have any idea how to find the root directory and anything I look up doesn’t make sense.

Things I have tried

I’ve researched how to find the root and attempted a couple of things but I really have no idea what I’m doing.

The root of your theme is simply the top folder. In the screenshot below it would be the folder, “Sample Theme”

And it is saying to add:

YourTheme/.github/workflows/release.yml

If you go to download the sample theme, you can see this folder and that particular file. Folders with . at the start are hidden by default, so you might have to show hidden folders in your OS.

But I don’t have that folder.

I tried adding it but Step 2 doesn’t execute.

It seems you added it but then deleted it somehow.

I deleted it because it didn’t work. I added it back just now and and when I tried to put Step 2 into the terminal I got this again:

fatal: not a git repository (or any of the parent directories): .git
fatal: not a git repository (or any of the parent directories): .git
fatal: not a git repository (or any of the parent directories): .git

The command has to be entered in the directory of the repository. The error is complaining that your current directory isn’t a git repo, which should has a .git sub-directory.

Would you mind sending a screenshot of how to do that please?

You seem had successfully pushed that file.

Before you push a tag in step 3, remember to update version in manifest.json first, or obsidian may dont know you have updated a newer version.

Given that tag 1.0.1 is used, pushing a new 1.0.2 may save some effort. (version in manifest to 1.0.2 too)

I don’t understand what this is or how to do it

Thank you for you help. I’m going to watch a tutorial on how to use github because I have no idea how to execute commands like that for a repository.

Did you also accidentally delete the .git folder from Reshi?

the_tree is showing a parent folder as your git repository. But I guess “Reshi” should actually be your git repository, right?

When you executed the git add command, which directory were you in? You should change the current directory to be in “Reshi” where a .git folder should exist.

That would be a good idea. Practice on a test repository and get comfortable with basic git commands. And remember git is the tool, Github is just one particular website where you can sync git repos. “how to use Github” should find you plenty of tutorials, but you are also learning “how to use git”. That distinction might help you when you are googling. Especially for basic errors and commands.