How Can I figure out why a note will not sync?

I have a note in my vault that will not sync. If you look at sync history it says no previous versions and it’s not mentioned in the sync log. However, it is in a folder that is set to sync. And if I put other notes in that folder, they do sync. Are there any additional logs that can show why I can’t get this file to sync? This caused a big issue for me yesterday when I opened up my iPad expecting to use this note and could not find it anywhere.

Things I have tried

  1. Moving the note in and out of the synced folder.
  2. Renaming the note.
  3. Restarting Obsidian on my iPad.
  4. Viewing all the logs.
  5. Syncing other files in the same vault.

What I’m trying to do

I want all notes in the synced folder in the vault to sync.

What is the name of the note?

In this case “AG Devotionals 2.” And I’ve seen this with a few other notes. All have just letters/numbers in the note name. One had parenthesis in the note name but that was the only non number or letter.

I wonder if Dropbox is the issue. I keep all my documents on Dropbox mainly to have a backup. I’m not trying to sync Obsidian using Dropbox I’m using Obsidian Sync to Sync between devices. But I saw one message in the forum that using Obsidian Sync on a vault in a Dropbox folder could create a problem. However I didn’t see that in the official documentation.

I moved my vault outside my dropbox folder and it may have solved the problem. But the problem is erratic so it will take a few days to know for sure.

But that’s what it does. If it’s only on one device, maybe it’s ok…? I don’t know really.

I can’t imagine why it would stop a single file from syncing though.

I checked the documentation and I couldn’t find it either. There used to be a warning somewhere in a sync guide that warns that using multiple syncing tools combined heightens the risk for race conditions and data loss. I highly recommend not to mix syncing tools.


One other idea about why a single file wouldn’t sync. Is there any chance you used the setting “Files & Links” → “Excluded files”?

Oh! I didn’t read closely enough. It’s probably because you have a period in the file name. That isn’t allowed in Obsidian.

The . and the “” are not in the file name.

I’m posting this in case anyone else runs into this problem. In my case my vault was in my dropbox folder although I only have one computer on that dropbox account. I was only using dropbox as a backup not to sync between multiple devices. However, Obsidian sync acted very strange when the vault was in the dropbox folder.

I moved my Obsidian vault out of the dropbox folder and so far sync seems to be working perfectly. So it seems that Obsidian sync does conflict with Dropbox or visa versa.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.