How can I auto-capitalize the first word in list items?

What I’m trying to do

Have obsidian consistently capitalize the first word in a new list item. If you end the item’s first sentence with a period, subsequent sentences are capitalized correctly.

This happens consistently with a bullet lists, and occasionally with numbered lists.

Things I have tried

Searched the help docs. Searched go duck go. Searched the Obsidian forum. Looked at the troubleshooting page.

However, I found the same behavior in the sandbox vault: while normal paragraphs always started with a capital letter, list items are usually not. Occasionally one is capitalized, and after that one, subsequent items are capitalized.

I also, one by one, turned off any plug-in that may have anything to do with text entry or formatting.

I don’t think it’s a setting in my macOS, since I tried this in Apple Notes and list items capitalized perfectly.

Any ideas what’s wrong?

Can you do a test here in the forum, and see what happens? And mention which browser you’re testing it in. (I’d say, test in a browser that isn’t Safari, because a Mac browser might work where others won’t.)

None of the MacOS autocorrection seems to work in Firefox browser for me. And not Obsidian either. So I wonder, maybe this is an upstream thing with Electron (Chromium, or maybe browsers in general).

Apparently, in this forum you have to type a list and then select it and click the bullets Icon.
So, you can’t duplicate hitting return at the end of a bulleted item to create the next bulleted item.

Do you know if Obsidian it’s supposed to auto-capitalize the first letter of a new bulleted item? Or does all auto-cap come from the OS?

I am 99% certain it only comes from the OS.

(But perhaps apps have to do something to support it from the OS. But that might be at the Chromium level, I’m not sure.)

Thanks. I’ll look into it from the OS angle.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.