Hotkeys.json is empty

Things I have tried

Turning on the “sync custom hotkeys” setting

What I’m trying to do

I want to sync my custom hotkeys between devices using Obsidian Sync. However, on my original device, despite the fact that I’ve added many custom hotkeys, the hotkeys.json file is empty: {}. Thus, the new device doesn’t get any of the custom hotkeys.

Did that file maybe get overwritten when you turned on sync? I haven’t been using Sync in a while. Is it possible there is version history of your hotkeys.json? I don’t know if that works only for notes: Version history - Obsidian Help

Are your hotkeys not working any more? You only mentioned the file was empty. If your hotkeys are still working, but the file is empty, maybe there is a duplicate sync-conflict hotkeys.json somewhere in your vault settings?

All else failing, do you keep backups that you can rollback to?

There is version history of all settings files, including hotkeys.json, and that fixed it! The blank app.json and hotkeys.json in the new vault overrode the filled-out ones in the old vault; restoring to the previous version solved everything. Thank you!

1 Like