Highlight hotkey only adds "==", but doesn't remove them, like bold or italics does

Steps to reproduce

in any file with text, on editor mode, select a couple words and activate the “highlight” hotkey (not set up by default) – this will add “==” at the beginning and end of selected words, making them highlighted
but, unlike the “bold” and “italics”, the repeating the same command doesn’t remove the “==”, as it does with the examples just mentioned

Expected result

I would like that the command to highlight to add “==” and also remove them after a second press, like it happens with bold/italics

Actual result

for now, it just keeps adding “==” to the selected words

Environment

  • Operating system: Windows 10

  • Obsidian version: 0.7.6


Additional information

2 Likes

will be fixed in 0.7.7.

1 Like

I am having the same (or similar) problem in Obsidian V0.11.13. In looking through the release notes I don’t see a release for 0.7.7. It jumps from .6 → .8 and nowhere do I see a fix for this problem mentioned. Has anyone found a work around for this?

As I was spanked by the moderator (regarding a different problem report) for having VIM key bindings set, I am assuring you that they are NOT set. Further, I was admonished to not submit a bug report if community plugins were set. I am assuring you that they are NOT set.

One difference I am seeing that the OP did not see: The OP reports that the highlight key is not set by default. In my installation it IS apparently set to ALT + SHFT + - by default. Also, as part of my trouble shooting I changed the hot key assignment and the problem persisted. It persisted when I reverted it back to it’s default. Any suggestion’s will be appreciated.

@unclebubba

  1. It has been fixed in 0.8.0 - see here
  2. As it is working (I tried again!) there is no need for a workaround. If it is not working for you, this should be caused by something else. What is your installer version?

AH, I must have been tired, as when I reviewed those release notes I did not see it hanging on it’s lonesome at the bottom of the list. Thanks for that pointer and I’m sorry for my carelessness.

The behavior is now as expected and documented, but ONLY after I changed the hot key assignment. I had changed it by replacing one of the keys with CTL (rather than ALT) and that did not help. I gave up there as I assumed :worried: that if one change did not help others would not either. In fact, I tried changing it to ALT + SHFT+ H, as suggested by akaalias, and magically it now works as advertised. In addition, it was wrapping with three === and now is using two == as it should.

This leaves the question of why I had to change the hot key assignment at all. And why others have the same problem. If it were just me, it could be easily explained by some hot key conflict, but I’m not sure how to find out what the conflict might be. In the hot key section of the Obsidian settings, if you set up a conflict it highlights both conflicting assignments in red. However, that does not rule out conflicts with other things. And it is not just me who has this problem. After all, akaalias had the problem and offered the work around. I’m currently fishing around for some app that will list ALL hotkey assignments and possibly highlight conflicts.

My installer version is: 0.8.1.

Thanks for getting back to me so quickly. I could have worked around it forever, but it is nice to close the loop, as it were, and now we can all sleep soundly free of nightly torments by renegade gangs of highlights. :grinning: Since others are having the same problem, it is apparently a real one. Should you wish me to test something toward the goal of fixing this, I’ll be happy to do what I can.

You should really update your obsidian version!

To what? I’m not an insider so I am running the latest release, as reported in the Obsidian settings. As an insider, you are two releases ahead of us peons living down here in the caves. I have automatic updates checked so it will update me when the powers that be determine that I am worthy. :smile:

=============

OK, Hold on now. This is seriously confusing. Just because I figured you could not be as dim as your suggestion indicated, after verifying that I had the latest update I went to the Obsidian website, threw caution to the wind, and got a NEW COPY of Obsidian, even though I apparently have the latest copy. What do you know? It updated the “installer version”. What is going on here? You are spot on. I was seriously back level even though Obsidian reported that I had the latest (and presumably greatest) version. How are we to know what to do about updating. Do we just do it every second Tuesday, to be sure? The developers need to put a warning on the “about” page to warn that the user cannot believe the “you are up to date” message and should just update any time something seems wrong. And why, oh why do automatic updates not update automatically?

Anyhow, I don’t know what will happen now with the phantom update you suggested, but I seriously appreciate your admonition to update. :+1:

I agree that obsidian’s updating habits are a bit confusing maybe… I am not sure if I am completely correct, but I think the “installer version” is the version of obsidian you have installed (for example, the version of your appimage), whereas the automatic updates seem to rather extend your installed version with some new features comparable to a plugin. It will add some updated stuff to obsidian’s config folders, but it doesn’t change your appimage. See here, though this is not really a detailed description.

In any case, if you have troubles with some obsidian functions, most of them should (at least if they are not caused by any plugins) be resolved if your installer version is not too much behind…

Yeah, that’s about as clear as mud. I guess there is some kind of technical issue they don’t want to address that will not allow them to auto update the “engine”. I can’t really imagine how this is all put together, but apparently Obsidian is two programs, something like an application running on top of an operating system. Whatever the case, I’m soldiering on with my work around. With the new “installer” updated, I still can’t do the highlighting with the default hot key. Fortunately, changing it has worked and I have a deep and abiding faith that some day magic will occur and it will be fixed … somehow. :smile:

Thanks again for your help.