Hiding File Path From Internal Links

Hello,

I’m a new user just getting the hang of things so forgive me if there is a simple solution for this.

I am doing the majority of my note taking with the Daily Notes feature, and then specific projects will get their own files. To preemptively keep everything organized, I’ve been using folders to store all the files. Now when I create internal links, it has the relative file path, which I understand is helpful for many users and also necessary if there are two files with the same name, but in different folders.

Is there a setting or plugin add on that will just visually shows only the file name as the internal link. I understand I can use the pipe | to create custom text for that link, but extra amount of text is discouraging me from using internal links.

Thanks!

1 Like

Go to settings, and under file, there’s a “New Link Format”. Here, just select “Shortest Path when possible”.

That should work.

1 Like

Thanks for the response!

I’ve played around with that setting. It still shows the FolderName/FileName in both the editor and the preview view.

1 Like

Ah the issue was that there was a duplicate file that I wasn’t seeing. If there is only one file then it presents it correctly.

Thanks for the help!

I have the same problem, already tried the solution proposed by Mayonnaise and made sure I don’t have duplicated file names. Any idea why I still see the file.path in the internal link?

1 Like

I’m having the same problem as well. I’ve configured all the settings accordingly but when I enter a link like [[Topic/Page]], it creates the folder and page (which is fantastic BTW), but it still displays the link as “Topic/Page”, instead of “Page” as I expected. Is there anything I’m missing?