Hidden notes accessible through search in publish


TLDR: When a note is marked as hidden client side, it is still searchable in the search bar on obsidian publish.

It is somewhat unclear whether this is a bug or a feature, I’m submitting it with the bug report layout under a feature request tag.

Ideally, a hidden note only shows up from [[hiddenNote]] or publish.obsidian.md/mysite/hiddenNote, not from the search bar on a publish site.

Ideal fix/feature

Hide hidden notes from the search function on the browser, perhaps with a tag search:false or otherwise

Steps to reproduce

Create a publish site, upload some notes. Turn on show navigation, List some notes as hidden using the publish setting menu, update changes and search for now hidden notes using the obsidian publish search feature.

Did you follow the troubleshooting guide? [Y/N]

I didn’t trial this in the troubleshooting guide. Sigrunixia said that the trial vault testing doesn’t apply in this case.

Expected result

“Hidden” notes not coming up on search, instead only visible through direct URL to page, or wiki link: [[hiddenPage]]


Obsidian version: v1.5.8
Installer version: v1.4.16
Operating system: Darwin Kernel Version 23.2.0: Wed Nov 15 21:53:34 PST 2023; root:xnu-10002.61.3~2/RELEASE_ARM64_T8103 23.2.0
Login status: logged in
Catalyst license: none
Insider build toggle: off
Live preview: on
Base theme: dark
Community theme: Border v1.7.10
Snippets enabled: 0
Restricted mode: off
Plugins installed: 22
Plugins enabled: 18
1: Surfing v0.8.16
2: Advanced Slides v1.20.0
3: Novel word count v3.3.4
4: Quick Latex v2.6.5
5: Avatar v1.0.5
6: Homepage v3.7.0
7: Dataview v0.5.64
8: Iconize v2.10.0
9: Table of Contents v0.2.0
10: Focus Mode v1.11.4
11: Excel to Markdown Table v0.4.0
12: Discord Rich Presence v1.5.1
13: Style Settings v1.0.7
14: Better Export PDF v1.5.6
15: Latex Suite v1.9.0
16: Desmos v0.6.6
17: Number Headings v1.16.0
18: Templater v2.2.3

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information