Help with git plugin. Err: pull failed

My Problem

Hello all, I am trying to set up the git community plugin.

  • I am using the appimage on Parot OS, mate (a debian variant).

as an aside, I was originally going to use Bryan Jenks scripts to do the same thing, but realized that there was a community plugin that did the same thing, which is awesome. These scripts are referenced in the git plugin info page.

I created a new repo in my git and followed the instructions for:

I also used the information here to Config Username & Password – Store Credentials

Here is a screenshot of the error messages received from git.

It is entirely possible I did something wrong. I am new to linux and using the terminal.
Here are the contents of my /.git/config file

repositoryformatversion = 0
filemode = true
bare = false
logallrefupdates = true
[remote “origin”]
url =
fetch = +refs/heads/:refs/remotes/origin/

naturally, I changed the url, but there are no stored passwords stored in the url as suggested by the link: Config Username & Password – Store Credentials

  • note, I understand that storing the password credentials in a config file is not the most secure thing in the world

the manual pushing of the data to my github repo did work from the command line, because all my content was synced to it after following that tutorial listed for the git plugin: How to create a local repo and push it to GitHub


  1. what am I doing wrong?
  2. misc other questions about other ways to do this and perhaps more links or info to how credentials work.
  • what are some better options? Because I obviously don’t want to type in a password every interval of the github sync. How does it work with SSH? Any code to do this?

Hey fellas, I have fixed my problem if anyone else comes here with the same problem.

Here is what I did:

I reset my username / password in the url with:

Then I ran the following command to enable credential storage in the git repository.

  • $ git config credential.helper store

This worked whereas trying to set it globally, as I had done previously did not. This is what I did before that for some reason didn’t work (could have been operator error):

  • $ git config --global credential.helper store

Then, I used this link for info on specifying the corect branch to merge with. In my case was “main”
Git Pull Error: Please specify which branch you want to merge with

  • $ git branch --set-upstream-to=origin/main

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.