🙏 Help - My Plugin's Will Not Delete

Terribly sorry to be a pain but my plugins will not delete

Steps to reproduce

  1. Go to settings - community plugins
  2. click x to delete the plugin

Expected result

pressing X should delete the plugin, close the pop-up

Actual result

Pop up remains open nothing changes
so I close the pop-up
restart Obsidian
Plugin remains


Windows 10
Obsidian v0.12.19

Additional information

no, other than that this is a great product

1 Like

Can you take a screenshot or a screen recording of this happening?

I’m curious, what does the popup look like, after you click the X? I wonder if there is a glitch or something. Does it look like this?

A 2nd way you can uninstall is by clicking on the plugin, and going into its settings window. There, you find another “Disable” and “Uninstall” button. Is it the same result if you try that way?

Lastly, if that all fails, the manual workaround would be this:

(I recommend backing up your entire vault before ever attempting to manually delete files.)

  1. Go to your vault folder. YourVault/.obsidian/plugins
  2. Close Obsidian first to be safe. In that folder, you can delete the plugin directly. Each plugin has its own folder.
  3. There is also a file community-plugins.json which is a list of all the plugins you have installed. And you can delete the plugin from that text file. But you don’t have to. If the plugin folder doesn’t exist, it won’t show up in Obsidian anymore.

Thank you. Yes the pop up is as you presented in your message. I will try your solutions when I get home this evening. Thanks so much for the help!!

where is your vault actually stored? do you use a sync service?

1 Like


Yeah good point, because even if you follow those steps and can delete the plugins, it is still odd that you can’t uninstall them normally. It would be good to figure out what the actual problem is.

1 Like

@WhiteNoise @rigmarole i have my vault sync via google drive

@WhiteNoise @rigmarole


Good morning. So first apologies on my delay but I was not home until late evening due to some stuff happening around my project work.

I removed the plugins using your (@rigmarole) first method and all is fine from that perspective


So I have just tested removing another plugin via the traditional press the x method. The same problem occurs as mentioned in this request. (pop up does not disappear, plug in remains even when I reboot obsidian.


So I removed my vault from drive then added it back and resychned it.


whilst the same problem is happening with the pop-up. That is I press the x but nothing happens. What does happen now is that when I close and then re-open obsidian the plugin has gone

So I think it is in part at least a synch issue with drive.

Thank you for both your help on this. I can live with having to open and close obsidian its not a major issue

Is the vault installed locally or streamed?
Streaming will bring problems and Gdrive recently tried to switch lots of users to streaming their files. There is the option to have files locally, but it needs to be selected.


Hi @Dor ahh Google pushed me into stream I will look into this and see if it helps. Thank you

um I think you are missing a step. From theh community plugins window you click an X next to the enable or disable slider to uninstall a plugin. Then you should get the pop up as described by the poster above. On thatPop up you must click the UNINSTALL button not the X.

X in the popup is a cancel and will not do the uninstall. It’s a backup in case you clicked uninstall by accident and have decided not to uninstall the plugin.

Maybe I’m misunderstanding your problem?

1 Like

apologies it was my description that was the problem, I forgot to mention I had clicked the uninstall wich did not work as also the x did not work wither. My apologies for the confusion caused

No worries. I’ve been dealing with simple issues not wuite but almost as bad as Is the computer plugged in? So I’m nvessarialy rather picky abot exacy clicks and what happens.

1 Like

:rofl::rofl::rofl::rofl:yes it’s plugged in (he just double checks!!!)

1 Like

I’m having the exact same problem as described by OP.

Uninstalling a plugin (whichever way you do it) doesn’t work immediately. It looks like nothing happens. But then when I close and re-open Obsidian it shows the plugin is gone.

It’s not a big deal, but it is clearly a bug.

Edit: My Obsidian folder is being backed up to Google Drive as well. I’m not streaming the folder from Google drive, the folder is primarily on my hard drive, but I’m backing it up to Google Drive automatically.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.