Help installing Dashboard++

More Strange behavior…? This morning I rebooted my Mac Mini (M2), reopened Obsidian, clicked the folder icon under Settings->Appearance->CSS Snippets and this time it did open the .Obsidian folder but then showed the Plugins folder instead of Snippets.

I’ve been trying to install the Dashboard++ CSS in Obsidian but I’ve had trouble getting it to work.

What trouble are you having getting it to work?

The snippets folder is just a folder on your computer. If there is a weird glitch with the folder button, you can simply navigate there manually in Finder.

If there is no YourVault/.obsidian/snippets folder already, you can make it yourself and drop the files in there.

1 Like

Yeah, I’ve been navigating there regularly now so that’s not really a problem anymore. Though, it does seem there is something glitchy with my folder button.

That’s the question I’m asking myself right now… and I’m scratching my head. I downloaded an example vault with Dashboard++ and the needed plugins pre-installed from the author and that works fine. But when i try it in my main vault, I can’t get it to work. I’ve been comparing settings between the example vault and my own but haven’t examined everything yet. Time consuming. There must be some setting or other plugin that I’m using that’s causing it to not work…

Just to make sure, Dashboard++ is a collection of CSS snippets. There are no plugins involved. Are you maybe putting the snippets in the plugins folder accidentally?

This does sound unrelated, and off-topic for this thread (and forum).

@Nats since you are asking for help with Dashboard++, this is unrelated to the previous topic, so I split it into a new topic for you.


They are in the right place. I did just check again.

  1. Is dashboard the snippet enabled? 2) have you applied the dashboard cssclass to your dashboard notes?

In addition to what others have mentioned, keep in mind the standard Dashboard++ snippet only affects Reading view. i.e. You won’t see any changes in the editor (Source mode or Live Preview) even if everything is set up correctly and enabled.

Don’t know if that’s the case here, but that is sometimes a cause of confusion.

1 Like

Yes. The dashboard snippet is enabled.

Yes… or at least I’ve tried. When I attempt to write in the cssclasses: dashboard, I get properties displayed like the following screenshot. Is that correct?

CleanShot 2024-05-06 at 08.21.51

Yes, that looks correct. And finally, are you switching to reading mode, as is required like @ariehen mentioned?

I’ve been using the author’s sample list as my test document. This is what it looks like in Reading Mode:

And this is Editing Mode:

When I first tried it, I wasn’t aware of that distinction. But then I did go back and read the instructions and realized it was only for Reading view. Thanks for mentioning it because it is easy to miss.

That empty [] looks a bit like a broken link. Maybe that is breaking the parsing for the rest of the note?

Although I tried adding an empty Markdown link between the header and list, and it didn’t break for me. So I’m not sure.

Thanks for that suggestion. I just checked and all those [] have links that are active and work. So that doesn’t seem to be the issue.

I guess I could probably build my own dashboard using the plugin Multi-Column Markdown, which I already have installed. I was just hoping to save some effort by using someone else’s creation. Definitely not saving time anymore. This is turning into its own mini-project, troubleshooting this thing. I’m feeling like maybe I need to figure this out because something important might be messed up in my setup… or perhaps this is so basic that if I can’t do this then I need to learn how…

Maybe that’s why. Try disabling it and see if that fixes Dashboard++. Maybe the CSS is fighting each other.

I had previously disabled that plugin and had the same result. I did just try again, disabled it, pressed the refresh button symbol, closed and reopened Obsidian, and then tested Dashboard++. Unfortunately, it still didn’t work…

1 Like

Hey, I found the problem. I compared the snippet I had downloaded with the snippet in the sample vault and noticed a slight difference. So I copied the one in the practice vault and then took that copy and tried it in my vault. It worked.

The copy that didn’t work was the Dashboard++ snippet but had a few extra CSS instructions at the top. I’m not sure how or where I downloaded the wrong one…

Thanks so much for the support and suggestions.