Headings with Numbers miss in TOC (Outline of Heading)

I think this could be related to a past bug report: Linking to the note heading with a number.number omits the period


Create a Markdown file as usual, set a heading (any level heading will have this issue, just use the hash tag prefixes followed by a space and your heading name).

Change the heading name to include a number and a dot or a right parenthesis.

Notice now the TOC lost the heading number!

Screenshot: Green arrows show correct TOC (Outline of Heading) and the red show the incorrect interpretation due to loss of the prefix numbering.


The TOC heading number should be there.

Work around for now:

I started using hyphens (even though it looks ugly) instead of a dot or a parenthesis as it should be in a heading and it works just for my notes, not for sharing as that may confuse people.


no, it’s not related to that.

This happens because now the the heading in the outline are heavily sanitized.

I also think the numbers in the red arrows should be kept in the TOC



i have a similarly problem:

In the h1-Header:

  • with the point, the one will not be show.
  • without the point, the one will be show.

best wishes


Found another thread, discussing the same matter:

Hi @mzee, I have the same problem.

I find that numbered lists are often fundamental for structuring a text and for an overall vision in the TOC. Can anyone tell us if there is a fix for this problem?

1 Like

+1 that numbers shouldn’t be stripped from the TOC! Please. :pray:t3:


+1 please

@WhiteNoise are we planning to correct this please?


+1 here



Same here.


Since Version 1.4.16 (Installer 1.4.13) this issue seem to have gotten worse.
None of the numbering appear now in the Outline view.

Notice now all levels not showing the numbering in the Outline view.

Expected behaviour is to show the content of the heading as-is in the Outline view.

1 Like

Completely agree! This is very frustrating behavior. At least it should be optional (maybe some toggle in the settings)

1 Like

Team, can we get this fixed please?


If this isn’t planned to be fixed in the short run, it’s a good idea to make a plugin that fixes this instead. And I’m pretty sure it’s not that hard.

You can refer to this code to render MathJax in the outline for how to modify what’s displayed in it.

Hey, I found a better workaround than the OP’s hyphen.

Just use non-breaking space after the dot instead of a normal space.

On mac you can make a non-breaking space with Alt+Space. Imperfect, but probably the best we have for now.


Hey, I wrote a plugin to fix this. Hope it helps!

1 Like

Hi, I tried to install, but it is still showing the same.

Also, I tried Alt+Space, but it didn’t help either.

@binjomin Can you send me a copy of the note that my plugin failed on?

Now I can confirm it’s it was not working and this is was due to the update from Obsidian v1.4 to v.1.5.
I will try to fix it. I have fixed it and released it as v0.2.0.
Thank you for letting me know.

FYI, the Quiet Outline plugin has a more advanced feature (but not Obsidian’s native outline view).

will be fixed 1.5.4

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.