Headings sometimes don't apply styling

Often if I do a heading, the formatting doesn’t apply. See the video here.

I cant figure out how to reproduce it. Anyone else seen anything like this?

That looks weird… Are you using a custom theme? Have you tried to deactivate it?

Nothing set up specifically no. It’s driving me kind of nuts!

curious to know what happens if you backspace (delete) the space between the heading tag (hashtags) and the heading, then reinsert that space. Does that fix the issue?

Yes, that fixes it

not really a fix though is it? this behaviour happens across my system in any and all apps that support markdown. so so weird. Have lived it with so long that i type that backspace automatically now.

Ah that’s super interesting. I have noticed the same thing happening in other apps too. Thought I was going mad! I wonder what the cause could be?

I’ve tried to figure it out for years. Drives me bananas. No idea why (and quite hard to do a specific search to hunt down the problem).

Let me know if you have any luck.

I am using the Clubouse.io text field and the markdown fails to apply on H2s there as well! This is crazy.

Could it be that the OS is inserting some sort of unusual space character after the two hashes? I’m completely stumped as to how this happens, or if it happens to everyone on a mac?!

hi @dabeeeenster – I thought you’d be interested to know that I think I found my problem.

I have a new computer and wasn’t able to replicate this problem until I changed the keyboard (input source) to British. Then it started immediately and happens every time. If I turn the input source back to ABC (which is what the default was) then the problem disappears.

So maybe take a look at input source (assuming you are running Mac OS) and see how it goes? It’s a bit hacky but maybe helpful.

Cheers
Simon

Hi @skiptime sorry only just saw your reply. It does indeed fix the issue!

Only problem is that the shortcuts for £ and # are now transposed. Maddening.