Heading Level Indent plugin stops working with Minimal theme

I was using Minimal theme with the plugin Heading Level Indent. Two days ago I updated plugins and themes, now Heading Level Indent doesn’t work with Minimal but does work with Dracula Official and Things themes.

I prefer Minimal because it is easy to customize with the plugin Minimal Theme Settings and Style Settings. But I really appreciate Heading Level Indent which should, in my opinion, be a core plugin.

I know the problem is with my vault because on other vaults Heading Level Indent works with Minimal.

I have tried some debugging by deactivating all other plugins, but that didn’t fix the problem.

How can I find where the problem is and fix this ?

Did you restart the app after disabling the plugins? That"s sometimes needed to fully unload them.

Just to be sure, I tried again. I disabled all the plugins and even turned on restricted mode. Quit the app. Restarted it. Same thing: If I activate one plugin, just Heading Level Indent and nothing else, the headings are not indented if the theme is Minimal but it works if I change the theme to Blue Topaz or Things.

And in a different vault, this does not happen.

Minimal recently had a major re-write (version 7). That could have something to do with it.

Someone (I’m guessing you’re not blablack :blush:) posted the same on the plugin’s Github page:

Well, it’s good to know that I’m not alone :wink:

All my themes and plugins are up to date :
Obsidian v1.3.7 on a Mac
Heading Level Indent v1.0.3
Minimal v7.0.7

I’m having this same issue. Has there been any update to address the issue?

Btw, I love the idea of this plugin and can’t wait to use it :slight_smile:

Have a look on Github: No indentation with Minimal theme · Issue #9 · svonjoi/obsidian-heading-level-indent · GitHub
This is a temporary workaround until the problem is fixed in Minimal.
You just need to deactivate “Readable line length” in the settings for Editor. It works for me.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.