Having trouble getting my vault to open under Wayland

I wasn’t sure whether to post this under bug reports or help, but given it may be something specific to the flatpak version of obsidian I chose help.

This has been going on for a while and seems isolated to a specific vault(my main vault). it simply won’t open with the environment variable OBSIDIAN_USE_WAYLAND=1 set via flatseal. previously if I tried to open it a few times it would open the main menu, then I could chose a vault, where if I chose another much smaller vault it seemed to work fine, but if I chose my main vault it would just close.

I’m fairly new to flatpak, but launching it from the commandline doesn’t seem to display any relevant information. I’d definitely be willing to collect logs and post them here if someone could point me to some resource as to how.

Things I have tried

launch the obsidian flatpak with variable OBSIDIAN_USE_WAYLAND=1 under wayland from the commandline

launch the obsidian flatpak under wayland with variable OBSIDIAN_USE_WAYLAND=1 from my application launcher (wofi)

What I’m trying to do

open my vault

seems the issue was related to poor handling of #, which caused my vault to refuse to open under wayland. after removing the one file in my vault with that symbol and removing .obsidian(may not have been necessary but mentioning in case it was) the vault now opens under wayland

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.