Hashtag can disappear depending on formatting

Hello everyone.

I’m a newbie here and with Obsidian as app too. Noticed some weird behavior when using tags in italic or bold text. Screenshot below:

When they are in regular text, everything is OK. But if I use them inside italicized or bold text, they look like unexpectedly torn at red line, without hash sign and with broken border displayed. And what’s more, that doesn’t depend on what theme I use.

Is it intended behavior? How I can fix it, possibly with custom CSS? I tried by myself, but didn’t succeed, CSS knowledge is too low.

Ideally, it should be displayed as regular/italic/bold text, but without any border, with hash sign and in other color.

Thank you.

It’s hard to tell what’s happening when we don’t see the markdown which is used. So please show the markdown (with four backticks, ```` before and after the markdown).

@holroy
Thank you for the answer. Nothing special, actually.

Lorem ipsum dolor sit amet, consectetur adipiscing elit, Fusce-eu-velit nisl. Vivamus vestibulum, sapien vel finibus accumsan, quam lacus consectetur nunc, non ornare ligula nisi sit amet neque.

Lorem ipsum dolor sit amet, consectetur adipiscing elit, #Fusce-eu-velit nisl. Vivamus vestibulum, sapien vel finibus accumsan, quam lacus consectetur nunc, non ornare ligula nisi sit amet neque.

Lorem ipsum dolor sit amet, **consectetur adipiscing elit, Fusce-eu-velit nisl**. Vivamus vestibulum, sapien vel finibus accumsan, quam lacus consectetur nunc, non ornare ligula nisi sit amet neque.

Lorem ipsum dolor sit amet, **consectetur adipiscing elit, #Fusce-eu-velit nisl**. Vivamus vestibulum, sapien vel finibus accumsan, quam lacus consectetur nunc, non ornare ligula nisi sit amet neque.

Lorem ipsum dolor sit amet, *consectetur adipiscing elit, Fusce-eu-velit nisl*. Vivamus vestibulum, sapien vel finibus accumsan, quam lacus consectetur nunc, non ornare ligula nisi sit amet neque.

Lorem ipsum dolor sit amet, *consectetur adipiscing elit, #Fusce-eu-velit nisl*. Vivamus vestibulum, sapien vel finibus accumsan, quam lacus consectetur nunc, non ornare ligula nisi sit amet neque.

By experimenting with CSS, I managed to know that’s issue with Live Preview mode.
If one disable it, switching to source code, it displays normally in both source code and reading mode.

Seems like real bug.

1 Like

I see the same in my vault and the sandbox.

1 Like

Thank you so much for confirming!

I wonder if I can add #live-preview to this conversation or not. I can’t change start post, unfortunately…

So I simplified it even further, and I can confirm that I see the removal of the hashtag in live-preview when combined with bold, **, and italic, *, surrounds the tag.

Markdown for the image below as text
NO-TAG Sit amet, consectetur adipiscing elit, Fusce-eu-velit nisl. Vivamus  

TAG Sit amet, consectetur adipiscing elit, #Fusce-eu-velit nisl. Vivamus  

BOLD NO-TAG Sit amet, **consectetur adipiscing elit, Fusce-eu-velit nisl**. Vivamus  

BOLD TAG Sit amet, **consectetur adipiscing elit, #Fusce-eu-velit nisl**. Vivamus  

ITALIC NO-TAG Sit amet, *consectetur adipiscing elit, Fusce-eu-velit nisl*. Vivamus  

ITALIC TAG Sit amet, *consectetur adipiscing elit, #Fusce-eu-velit nisl*. Vivamus  

Editing modes to the left, source mode on top, and live-preview under, and reading mode to the right showing correctly. Live-preview is the only one missing the hash-tag, and with slightly different formatting for the tags.

Show debug info
SYSTEM INFO:
	Obsidian version: v1.1.9
	Installer version: v1.0.0
	Operating system: Darwin Kernel Version 18.7.0: Tue Jun 22 19:37:08 PDT 2021; root:xnu-4903.278.70~1/RELEASE_X86_64 18.7.0
	Login status: not logged in
	Insider build toggle: off
	Live preview: on
	Legacy editor: off
	Base theme: dark
	Community theme: none
	Snippets enabled: 0
	Restricted mode: off
	Plugins installed: 0
	Plugins enabled: 0

RECOMMENDATIONS:
	none
1 Like