Has anyone installed onto raspberry pi 4?

I am trying to install it on my Raspberry pi 4, has anyone done it? I am a newbie when installing on Linux and then running the appimage from the terminal.

Any help would be gratefully received

Raspberry Pi uses a different CPU architecture than traditional PCs. You’re gonna have to download ARM64 package from the bottom of this page (instead of the AppImage on the homepage):

To run it, you have two options:

  1. Right-click the AppImage, go into properties, and enable execution. Click or double click the file and Obsidian will run.
  2. Assuming it’s in your downloads folder, from the terminal:
    cd Downloads
    chmod +x file_name.appimage
    ./file_name.appimage
    

Which distribution are you using? The Obsidian flatpak supports both x86_64 and aarch64, and can be set up easily:

One of the advantages of using this method is that regardless of the distribution or CPU architecture, setup should be as simple as running:

$ flatpak remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo
$ flatpak install flathub md.obsidian.Obsidian
$ flatpak run md.obsidian.Obsidian

I get the following error when i try to run the app after following your instructions for the appimage

bash: ./Obsidian-0.9.17-arm64.AppImage: cannot execute binary file: Exec format error

I get the following error when attempting to install the flatpak

error: Nothing matches md.obsidian.Obsidian in remote flathub

flatpak remotes
Name    Options
flathub system

@marinersway Which distro are you using?

Also, can you show all of the commands you ran to set up leading up to installing the Obsidian flatpak?

You should be able to see Obsidian listed if you have flathub configured, like so:

$ flatpak remote-info flathub md.obsidian.Obsidian

Obsidian - Markdown-based knowledge base

        ID: md.obsidian.Obsidian
       Ref: app/md.obsidian.Obsidian/x86_64/stable
      Arch: x86_64
    Branch: stable
   Version: 0.9.17
   License: LicenseRef-proprietary=https://obsidian.md/eula
Collection: org.flathub.Stable
  Download: 91.4 MB
 Installed: 223.5 MB
   Runtime: org.freedesktop.Platform/x86_64/20.08
       Sdk: org.freedesktop.Sdk/x86_64/20.08

    Commit: d90cd8bf72dba120edefd36f2efef20368b726321c3e4a0f5573ffdb785c85c7
    Parent: 76dcb0fcc6a4aa6b47052960867fdbd6a7e75af43b399bd6091874101df3c5f4
   Subject: Add .ssh/ as a persistent folder (ed00e440)
      Date: 2020-12-04 17:29:45 +0000

I have the most recent raspberry pi OS

[email protected]:~ $ flatpak remote-info flathub md.obsidian.Obsidian
error: Error searching remote flathub: Can't find ref md.obsidian.Obsidian
[email protected]:~ $ sudo flatpak remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo
[email protected]:~ $ flatpak remote-info flathub md.obsidian.Obsidian
error: Error searching remote flathub: Can't find ref md.obsidian.Obsidian
[email protected]:~ $ flatpak install flathub md.obsidian.Obsidian
Looking for matches…
error: Nothing matches md.obsidian.Obsidian in remote flathub

As @input_sh mentioned above, as long as you get the ARM64 package AppImage and make the AppImage executable it will work. I made it work on my Pi4 however running Manjaro ARM which is 64bit. My guess is that you either haven’t made the AppImage executable or since Raspberry Pi OS is running a 32bit Kernel the ARM64 package isn’t compatible with it. You can switch to the 64bit Kernel on Raspberry Pi OS but I’d be mindful that it’s still WIP and you might run into other issues.

1 Like

Thank you, it needs 64bit to run. All sorted now. Thank you all

1 Like

Hello,
I couldn’t make it run on my side: I would rather not move to the beta 64 bits raspberry OS only for Obsidian to run. Is there any other way I could achieve that?

Hi there,

Were you able to use it? I have a Raspberry Pi 400 and I haven’t been able with any of the images.
Could you please explain how you did it?
Thanks a lot!

Yes, needs a 64bit os

Which package from https://obsidian.md/download did you use? I haven’t been able to execute any of those. Do you have the same Raspberry 400? Because it has the 64bit but this is the first time I have a Raspberry and maybe I am missing something

Thanks a lot for your help

@algazaras did you manage to resolve your issue?

No, I wasn’t able to use it in Raspberry. I tried several versions and then I abandoned :frowning:
It’s a pity

Works with 64 bit OS, raspberry pi is comes in 2 forms with 32bit being used mainly. Download 64 bit version.

I have tested it on Manjaro XFCE, Ubuntu 20.10 and Raspberry Pi OS 64bit. I can confirm its working on all three. Ubuntu didn’t like the Appimage package but installing via Flatpak worked well.

You need to use this Appimage - https://github.com/obsidianmd/obsidian-releases/releases/download/v0.9.17/Obsidian-0.9.17-arm64.AppImage.

1 Like