Hangs for 4 seconds every time I switch to other note

Once you’ve done the above, delete everything above this line.

Steps to reproduce

Open Obsidian and open a note. The interface will freeze for 4-5 seconds. Then open another. It will freeze again. Then switch to the previous one. It will freeze again.

Did you follow the troubleshooting guide? Y

  • This happens in sandbox vault
  • I uninstalled and reinstalled Obsidian and the problem remains

Expected result

I expected it to not hang as it used to do.

Actual result

The interface freezes every time I switch to another note.


Obsidian version: v1.5.3
Installer version: v1.5.3
Operating system: Darwin Kernel Version 23.3.0: Wed Dec 20 21:28:58 PST 2023; root:xnu-10002.81.5~7/RELEASE_X86_64 23.3.0
Login status: logged in
Catalyst license: insider
Insider build toggle: off
Live preview: on
Base theme: light
Community theme: AnuPpuccin v1.4.5
Snippets enabled: 4
Restricted mode: off
Plugins installed: 42
Plugins enabled: 32
1: Advanced URI v1.40.0
2: Auto Note Mover v1.2.0
3: Base Tag Renderer v1.2.1
4: Buttons v0.5.1
5: Calendar v1.5.10
6: Dataview v0.5.64
7: Emoji Shortcodes v2.2.0
8: Linter v1.22.0
9: Map View v4.0.0
10: Minimal Theme Settings v7.3.1
11: Natural Language Dates v0.6.2
12: Outliner v4.8.0
13: Periodic Notes v0.0.17
14: PlantUML v1.7.0
15: Plugin Update Tracker v1.5.2
16: QuickAdd v1.6.1
17: Show Whitespace v0.3.1
18: Templater v2.2.1
19: DB Folder v3.5.1
20: Fast Image Cleaner v0.8.2
21: Filename Heading Sync v1.9.0
22: Book Search v0.5.11
23: MetaEdit v1.8.2
24: Hotkeys for specific files v1.4.1
25: Projects v1.17.1
26: Simple Embeds v1.15.0
27: Tasks v6.0.0
28: Excalidraw v2.0.20
29: Keyword Highlighter v1.2.0
30: Omnisearch v1.21.1
31: Recent Files v1.3.10
32: Multi-Column Markdown v0.9.1

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

Thank you.

Please, Post a screen recording of this happening in the sandbox vault.

As it “used to do” before you changed what?

In my experience, long hang times on open are often due to one or more Dataview queries rebuilding.

Or perhaps do you have any queries pinned to a window or a sidebar that run over all the pages in your vault?

1 Like

Here is a screen recording of me interacting with the sandbox vault. I’m trying to scroll the whole time but as you can see it stalls for several seconds every time I switch to another file. The spinning wheel cursor shows for most of the time while it’s stuck but for some reason the screen recording doesn’t show it. I hope this helps.

Screen Recording 2024-02-18 at 14.16.59.mp4.zip (2.4 MB)

As far as I know, nothing besides keeping it up to date.

Indeed. I also had a similar issue with plugin “List Modified” when a lot of files get updated at one time.

But this is happening in the sandbox vault too :frowning:

I don’t know. Is it possible that you have a problem with you filesystem? Do you use some form of network storage?

Do you have obsidian installed on multiple users on the same machine?

No. Just one user. All normal in my file system: my MacBook Pro internal SSD. I really don’t know what to do but this is making Obsidian unusable since I constantly switch between multiple notes :frowning:

I don’t see any error related to this in the console.
Please help! I rely on Obsidian and it is currently unusable…

I just completely removed Obsidian again and reinstalled it with the latest insider v1.5.7 and my problem remains.

I think this is something specific to your system.

Have you restart you mac?

Does it happen when only the sandbox vault is open?

What else have you installed/enable in your computer recently?

Oh man… 10x thank you and 10x sorry.

I tried so many things but when I read what you said I thought… “could it be that I didn’t restart the mac!!!”.

I restarted it and now it works fine. Problem solved.

Sorry everyone for wasting your time.

Thank you again! Sorry again!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.