Group/Node colors and other settings not saving

Started using Obsidian yesterday, but for some reason my group colors I set (and other settings like turning off folded headings) aren’t saving when I reopen the vault. I’ve tried reinstalling or even installing it on separate drives, but no fix yet. Any ideas?

Reinstalling the app doesn’t change your settings. Your vault settings are stored inside your vault. So if you are reinstalling Obsidian on different drives, that won’t make a difference.

  1. Are you using the Obsidian Sandbox vault by any chance? That doesn’t save your settings or content. It resets every time. You need to make your own vault.

  2. Where did you store your vault? Are you willing to share the full path you are using? Are you putting your vault inside some cloud/sync vault? This might be a bug related to that.

  3. Can you please paste the results of the Obsidian command “Show debug info”?

This is a vault on a hard drive with the most recent version of Obsidian. It saves the actual notes and contents, just not any of my settings. The vault is on another internal hard drive on my system that I use as a separate Documents folder. I tried putting it on my C drive just to see if that would fix it, but that didn’t seem to change anything.

SYSTEM INFO:
Obsidian version: v0.15.9
Installer version: v0.15.9
Operating system: Windows 10 Home 10.0.19044
Login status: not logged in
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 0
Restricted mode: on

RECOMMENDATIONS:
none

Yeah I’m trying to isolate if you’re using some kind of cloud-like setup that would cause file conflicts. Go look inside your vault/.obsidian folder and look around for conflicted files. That can prevent settings from being saved properly.

If your settings are already messed up, then moving the vault isn’t going to fix it.

This sounds quite suspicious to me and I wonder if this has something to do with your problem. What do you mean “that I use as a separate Documents folder”? Did you set your vault to some existing folder that already contains other files?