Graph view nodes are the same colour as the background and CSS snippets don't seem to work

What I’m trying to do

I want to navigate my notes using the graph view on my laptop. When I open up graph view, it shows edges and labels, but the nodes are not visible.

If I hover over a node, its outline becomes visible, but the node remains invisible.

In case it is relevant, I am running Obsidian on Arch linux with i3wm. Obsidian says it is at version 1.3.7. I installed it from the AUR.

Things I have tried

I searched for “graph nodes invisible” on the internet, found the Obsidian forum, in which I found some CSS related posts. Through that I discovered the CSS snippets functionality; however, using snippets seem to not have any effect. I thought this might be because of line-end character conventions, but switching the file between dos mode and unix mode in my editor doesn’t seem to have any effect.

Here is the content of graph.css in my custom snippets folder. I added bits and pieces until it looked like this, at no stage did it seem to make any difference:

.graph-view.color-fill-focused {
  color: red;

.graph-view.color-fill {
  color: #a08db9;
.graph-view.color-fill-unresolved {
  color: #8db5c9;

.graph-view {
    --graph-node: #FCF601;
    --graph-node-unresolved: #9E8AFF;

.theme-light .graph-view.color-fill-unresolved {
  color: #fde725; 

.graph-view.color-fill {
  color: var(red);

One of the forum posts suggested putting CSS in vault/obsidian.css to customize the appearance. I remember this working when I tried it last week, but it seems to have become ineffective - nothing I change in there has any effect now.

I thought the theme I had installed might be causing a problem, but going back to the default theme doesn’t change anything.

In the sandbox vault, at first the graph would not work at all; i.e. it didn’t show any nodes, edges or labels. I fiddled around with it some, and after adding some linked nodes in the sandbox, suddenly the graph worked. This is what I’d expect it to look like by default.

Did you manage to find the solution? I have the exact same problem.

I didn’t have this problem until upgrading to 1.4.13 on ubuntu 22.04, but now I do. Along with having to repeatedly delete .obsidian/graph.json to get anything to display at all

I also use Linux and have this same problem with Garuda Linux, which is Arch based. You can try deactivating the Hardware Acceleration from the Settings > About tab.

It worked for me but the graph became slow.