Graph view losing unpopulated nodes when clicked and returning to graph view

Steps to reproduce

Open graph view, enter a search term, click on node that does not have any content, but is linked to a node that does, click on the graph view icon again so that paine goes back to the graph view.

Expected result

when clicking back to the graph view, you’ll see the same set of nodes as was originally returned by the initial search.

Actual result

The graph view returns the nodes which appeared in the original search, except the one that was previously clicked on.


  • Operating system: windows 10 pro, version 1909
  • Obsidian version: v0.10.13

Additional information

Application running in safe mode, restarted application and missing nodes still do not show up in graph view.

On searching for that page/node, it does return in the search, and it is still in the base document as a link.

  • apologies if this is a duplicate report, but i couldn’t find any that matched.

did you have existing files on turned off?
Do the files that you clicked exist before or were they created the moment you click on them?

Can you post a screen recording, I am a little confused.

Hi, existing files only was set to off.

The files were not created before clicking on them in the graph view (they don’t show up as files in the search, other than as a reference on the parent page the ‘[[ ]]’ with the file name in.

Link to my literal screen recording! sorry no screen cap software installed on that machine!

Graph view issue link

I see. unfortunately, I can’t reproduce. If it doesn’t contain sensible information, can you zip the vault and DM to me on discord.

Do you have directories with weird names in your vault?

Are you using symbolic links?

not really, i have one with a leading underscore, but nothing too long or using strange characters. It is in a google drive folder rather than a typical Windows directory.

Does the link appear when you close and reopen obsidian?

Does this bug happen in a non google drive vault, like the help vault?

It’s possible that google drive doesn’t really create the file right away or maybe swaps for symbolic link.

No, the link is still not there when closing and re-opening the app.

The same issue is with the help vault where i’ve added blank pages using [[page name here]] method, and then repeating the process.

As it’s happening with the help vault, i can send you that on Discord, i’ve also now tried it on two different machines (connecting to the same google drive) and the same issue is appearing.

I came here because I found the same problem from another angle as I was setting up Obsidian, and creating tags with which to filter my graph view.

Problem: a graph filtered by tag still shows unpopulated and never-visited nodes. @Alex_d noticed that these disappeared from the graph view: that’s because he visited them - for some reason graph view always shows unpopulated, never-visited nodes.

I created loads of these (I think) when I imported my Roam graph. Every tag in Roam was transformed into a page with no content which I’ve never visited.

So here’s my question:

  • why on earth is Graph view showing unpopulated and never-visited nodes???
  • *how can I stop it happening?