Graph View locked wont let me open an editor

Steps to reproduce

I selected a graph pane, closed it out, moved to a text pane, selected back arrow in the top left.

Expected result

I expected the editor to go back to a previously selected page I’d opened there.

Actual result

Instead it took me back to the graph I’d closed out. I tried to reopen a file editor, but every node i selected in the graph, or in the file tree, simply took me to a different node while still displaying the graph.

I managed to escape the “graph lock” by selecting my pinned editor, splitting the pane and creating another editor. I was able to select files again and edit them aftewards… but if I hadn’t had an extra pane pinned, I don’t know if i would have been able to exit the graph view.

(I did not test if i could go forward to my editor instead back to my editor, and though i guess that might have worked, i wouldn’t have necessarily discovered this bug.)


  • Operating system: Windows 10
  • Obsidian version: v0.8.15

Additional information

The history in Obsidian is global (not per pane) so it’s normal that you went back to the local graph.

When only the the local graph pane was open, clicking on another file in file explorer opens the local graph of that file.

If you want to open in a new pane you can use ctrl-click

1 Like

Thank you! That helps my understanding of what happened then.