Graph view don't work on Ubuntu 22.04

I open Graph view not really often, but recently I did and saw just blank page. After some tinkering with settings, updating plugins an so on I found out that if I split graph view, new tab will show graph, but only edges are visible. I can interact with vertices/nodes but they are invisible.

System info:

  • OS: Ubuntu 22.04
  • Obsidian version: 1.5.11 (installed via snap)

I tried to restart laptop, it doesn’t help.

Try deleting the GPUCache cache file.

Moved to help for not following or including the bug report template.

Thank you for reply. Did you mean snap/chromium/common/chromium/Default/GPUCache? I just tried to delete it, but nothing changed.

Thus far, I always deleted all contents of .config/obsidian to restore the graph. That to me does not appear to do much harm, but next time, I will try whether indeed just deleting ~/.config/obsidian/GPUCache helps. Indeed, the graph view appears to break now and then on Linux.

What you now did was deleting that cache for the Chromium browser application, not for Obsidian. For a “snap” installation, the corresponding configuration data is stored under a folder of the application under the “~/snap” directory. So look for a folder Obsidian there.

Interesting. My first move was to search whole home directory for GPUCache folder via fzf and chromium is the only one present on my system. Also, it appears that there is no obsidian folder in my ~/.config.

It depends on how Obsidian is installed. I use the appimage. This creates the config folder under ~/.config/obsidian, a standard location also for applications installed using the traditional APT system of Debian and thus also Ubuntu. If your Obsidian is installed as a snap, its config folder will live under ~/snap. For flatpak installs, it will be under ~/.var/app.

1 Like

I just reinstalled obsidian and graph now works fine.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.