Graph view colors not persisting after restart

Steps to reproduce

Open obsidian, expect to see the colors saved in graph

Did you follow the troubleshooting guide? [Y/N] Y

Y, i tried in a sandbox vault, but i cannot reproduce the issue because the colors in the graph menu only reset to grey when restarting the application. The sandbox vault does not save after restart.

Expected result

I expect to see the colors of the groups I have set in the graph view. They still work on mobile.

Actual result

The graph colors are all grey. IF i delete the ~/.config/obsidian folder and open obsidian (have to remake the vault), the colors will be there, but if i restart the application, the colors are all grey. If I reset the graph view settings to default, i can remake the groups and the colors show up, but this still does not persist after restart.


Additional information

Obsidian version: v1.4.5
Installer version: v1.3.7
Operating system: #1 SMP PREEMPT_DYNAMIC Sat, 19 Aug 2023 15:38:34 +0000 6.4.11-arch2-1
Login status: not logged in
Insider build toggle: off
Live preview: off
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 0
Restricted mode: off
Plugins installed: 15
Plugins enabled: 0


This is really frustrating. I can’t even use an older version of the app that works because the appimage auto-updates itself.

1 Like

Experienced the same issue. At first, I thought I had a problem with the properties (cuz they were updated), but the content and file name do not work for me either.

1 Like

I can’t reproduce. Please, create a new vault a post a screen recording of this happening in that new vault.

Having the same issue and I was able to re-produce. Tried a new empty vault and copying my vault into a newly created vault - no luck.

The issue stems from the .config/obsidian/GPUCache/ folder. Deleting it provides a temporary solution, but the problem resurfaces after a certain period of time.

well, I am not sure about that.

Can anybody post a screen recording of this happening in a new vault/sandbox vault?

Same problem here. For me, problem occurs due to a group filter like:

line:(Groupe : amical)

“:” are no longer accepted on filter part without double quote.
It worked before the arrival of properties, but not any more.
It works now on creation but not on reload.

Problem solved now with this format:

line:("Groupe : amical")

Would that be your problem ?

Experiencing the same issue here - group colors reset to grey. I’m using Mac desktop version of Obsidian MD (Version 1.4.12).

@zebma is a valid explanation.

@Effervescence post a screen recording of this happening and what are your queries?

@WhiteNoise - I just noticed an update and it seems to be working fine now with Version 1.4.13 (Installer 1.4.5). Thank you :slight_smile: