Google fonts rendering in all bold, how do I modify font weights?

What I’m trying to do

I’m trying to switch to a font like Merriweather, Roboto, IBM Plex Serif it only renders in bold font.

See image:

What is supposed to be bold (yellow text) looks like the same weight as the regular text (white), both in read and edit view. This seems to only happen with Google fonts, the default Microsoft fonts and some other random ones I download around the web don’t have this problem. How do I modify font weights, or just have Obsidian load the proper weights?

I am on the Windows desktop version.

Things I have tried

  • Switching to default theme, still looks the same. Doesn’t appear to be a theme issue.
  • Tried different fonts - some render properly, some don’t. Seems to only happen with Google fonts, maybe they implement font weights differently? I could just use a different font but I would rather find a solution than settling on something else.
  • Modifying it in CSS - I don’t know what the proper CSS for this is. I tried the following and nothing changed.
body {

Just to double check, the font (and all its versions) you want to use is are installed on Windows? And where are you choosing the font to use? In Obsidian’s Settings > Appearance > Font -> Text font ?

It’s possible the font name isn’t correct or there are many versions of it, and for some reason only the bold version is being used for everything. I’ve seen odd things before if a font has lots of variations. :face_with_spiral_eyes:

If you say what font it is (and a download link of the exact one you are using), we can have a look to see what’s going on.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.