Google Drive not working

Opening a vault from Google Drive doesn’t work.

Steps to reproduce

  • open Obsidian
  • open a folder as Vault

Expected result

  • normal UI with folders and notes

Actual result

  • a bunch of random numbers, nothing is editable

Basically it’s this bug that is NOT FIXED: [SOLVED] Linux Mint & Google Drive


  • Operating system: Linux Mint 19.3
  • Obsidian version: 0.8.2

Additional information

A plugin to sync your notes with cloud services would go a long way…having to work Obsidian from a Google Drive folder means you cannot do anything if you don’t have access to the internet (and as you can see, it doesn’t even work now).

I don’t get it. I am not familiar with google drives.
Obsidian files are just regular files in the filesystem. If GDrive works like dropbox, there should be no problem.

Does google drive instead creates an encrypted folder on your harddrive and to access it you need to online and logged on?

Now that I think about, GDrive had the option of keeping VIRTUAL files on your hard disk and they are resolved to files in the cloud (downloaded on the fly) IF GDrive is running.

We don’t support this workflow (and most likely won’t implement first party plugin to support it)
If this is problem, you need to look into GDrive settings and configure so it actually maintains the Obsidian vault on your drive (not just virtual files).

To build on what @WhiteNoise noted, @Sophon, this is on Google’s end, sadly:

Unless there’s been a change since that article, Google does not provide a client for file syncing on Linux distros. Obsidian does not have any integrated syncing—that’s on the roadmap, but it will be Obsidian’s own service, not any of the cloud syncing solutions.

I recommend looking into sync services that provide file syncing clients on Linux.

For quite some time now Linux distros have (had?) a solution for Gdrive sync. Gnome and KDE desktop environments each have a different approach to Google Accounts integration. I used to use KDE’s because of it’s file manager (Dolphin) that is much more customizable, but for almost two years (google’s fault) it stopped working. The next thing that worked was something called “Google Drive OCaml-Fuse”, that allowed gdrive to be mounted as a fuse-virtual drive on a local folder. To my surprise, I found out that Obsidian can’t see network folders when we open the native dialog on any linux distro. That’s the only reason I switched back to Windows. That’s a bummer…