GNOME: entering special characters does not work

How to enter special characters in GNOME using the compose key

“A compose key is a special key that allows you to press multiple keys in a row to get a special character.”

Like many, I am using a keyboard with a US English layout.

Unfortunately, GNOME’s compose key does not appear to work in Obsidian. This means that entering special characters necessitates the use of either the Characters application to copy and paste or another Markdown editor to work with the compose key.

This is quite disruptive to any kind of workflow as soon as writing in languages such as French, Spanish, Portugese, Italian or German (and probably many other languages) is required.

Obsidian is currently the only application installed on my GNOME desktop that does not work with the compose key. I would be most grateful if this issue could be addressed.

Steps to reproduce

Press [compose] then [’] then [e]

Press [compose] then ["] then [a]

Press [compose] then [s] then [s]

Expected result

é ä ß

Actual result

‘e’ “a” ss


  • Operating system:
    Debian GNU/Linux 11 (bullseye) x86_64
    GNOME 3.38.6

  • Debug info:
    Obsidian version: v0.13.19
    Installer version: v0.13.19
    Login status: not logged in
    Insider build toggle: off
    Live preview: on
    Legacy editor: off
    Base theme: dark
    Community theme: none
    Snippets enabled: 0
    Safe mode: on

No Additional information

This looks like a high level emulation of dead keys layouts. In practice it may work like a text expander (correction after input) as opposed to a true dead key keyboard.

what happens if you disable autocomplete markdown and autocomplete brackets?

Does it work here?

This is the output with Auto pair brackets and Auto pair Markdown syntax switched off:

'e "a ss

It does.