Global block reference not working

Steps to reproduce

  1. Go to any note
  2. Make empty link [[]]
  3. Type ^^ between link

Expected result

Block references for other notes should appear in auto-complete.

Actual result

Only block references for current note appear in auto-complete.


  • Operating system: macOS Mojave
  • Obsidian version: 0.9.17, though I’ve had this since block references were a new feature.

Additional information

I believe this bug seems to be unique in my case since nobody has reported anything similar as far as I’ve checked. I may be missing something about global block references or it is indeed a bug. Note sure what other info I can give other than it’s not working for me; I could give some sort of log file or something but not sure where to look and how to go about doing that.

Sometimes I encounter this behavior as well. In my case, if you delete the ^^ and type it again ^^ followed by the text then it works. It’s not a major issue or anything, but it’d a nice thing to improve.

Tried your suggestion; glad to know that global references do work for me… just undesirably sporadic. At my first try with your suggestion, it worked; next number of tries didn’t; then at one point, I didn’t need to delete and retype ^^.

In my case, it’s also a minor problem because I don’t use global block references that often; otherwise it’d be more than minor.

Have you guys tried to wait? Because if you just type [[^^ it means find every block in every file. Which clearly is a very complex operation and as your vault grows it takes longer.


That’s not an unreasonable thought, I waited for 3 seconds and the block references appear. I’d suggest adding a progress bar of some kind, but thanks, it works !


I think it would also be better to not show the current note’s blocks when loading global block references. I prefer to know that it’s just loading; doesn’t need to be a progress bar, could just even show the word “loading…” or something lol. Anyway, glad to know that this feature is working for me after all, thanks guys!

Now I’m having exactly this moment on one vault. But the other vault is still working fine. I type [[ and ^^ and wait for as long as I can but nothing happens. The waiting method is just don’t work.

I have tried to reload both the app and the workspace, also turn on/off Safe Mode for plugins but nothing changes.

Any thought?