Git Backup can't push

At least I don’t have commitment issues. :wink: (I have searched the forum and nothing else seems like this)

In past few days? Git Push to have failed. The error message is:

git obsidian error: Pushing to
fatal: could not read Username for ‘’: Device not configured

The console.log shows the following stack trace:
Uncaught (in promise) Error: Pushing to
fatal: could not read Username for ‘’: Device not configured

at Object.action (plugin:obsidian-git:29441:25)
at PluginStore.exec (plugin:obsidian-git:29466:25)
at eval (plugin:obsidian-git:26971:43)
at new Promise (<anonymous>)
at GitExecutorChain.handleTaskData (plugin:obsidian-git:26969:16)
at GitExecutorChain.eval (plugin:obsidian-git:26953:44)
at (<anonymous>)
at fulfilled (plugin:obsidian-git:25798:24)

The error seems strange, I check the local git config and my username is present. Further I can use the GitDesktop client to do the push manually, I just miss the automation. What have I missed?

What does it show in the plugin settings? Does it show that it should work?

Also, in your .git folder find the .gitconfig file, copy and paste it here.

.gitconfig == .git/config?

repositoryformatversion = 0
filemode = true
bare = false
logallrefupdates = true
ignorecase = true
precomposeunicode = true
[remote “origin”]
url =
fetch = +refs/heads/:refs/remotes/origin/
[branch “main”]
remote = origin
merge = refs/heads/main
repositoryformatversion = 0

email = [email protected]
name = Mark Levison

Not sure what Git Backup options to share. So I tried a scrolling capture (via CleanshotX)

Success, yesterday I tried the SSH route. Here there be dragons. Today inspired by the desire to close an open loop, I searched again and found: Set up Git - GitHub Docs going the HTTPS route got the job done in a minute.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.