(German) qwertz keyboard-layouts: Umlauts, `ß`, and `+` dont get displayed correctly in keyboard settings

Steps to reproduce

  • Have a (german) qwertz keyboard-layout
  • Go into the hotkey settings
  • Try to set a hotkey with ä, ö, ü, ß or +
  • be amused :slight_smile:

Did you follow the troubleshooting guide? [Y]

Yes, Sandbox vault.

Expected result

For the example with the shortcut cmd + ä id expect to see it displayed as cmd + ä in the hotkey settings.

Actual result

Instead it gets displayed as cmd + ' (The hotkey still works fine, its just wrongly displayed!)


Obsidian version: v1.3.7
Installer version: v1.3.7
Operating system: Darwin Kernel Version 22.1.0: Sun Oct 9 20:14:54 PDT 2022; root:xnu-8792.41.9~2/RELEASE_X86_64 22.1.0
Login status: not logged in
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 0
Restricted mode: on


Additional information

  • ä gets displayed as '
  • ü gets displayed as [
  • ö gets displayed as ;
  • ß gets displayed as -
  • + gets displayed as =

If i understand it correctly it just displays what is on the qwerty keyboard-layout at that position.

This is consistent with different keyboard layouts, in my case the https://neo-layout.org. On that layout the ä for example is where the c is on qwerty-layouts. The keyboard settings do show c when i try to set a shortcut with ä.

I note here, that z and ywork perfectly fine, eventhough those letters are on swapped positions in qwertz and qwerty, so its only doing weird stuff with weird characters.

Thank you very much for this app that completely engulfed me since the last week! <3

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.