Fuzzy search doesn't work in linking/autocomplete

Steps to reproduce

  1. Create a new vault
  2. Create two notes with names ‘Number One’ and ‘Number Two’
  3. In the first one, try typing [[nutwo
    – suggestion shows ‘Number Two’
  4. Copy over my notes on movies (2656 strictly .md files, nothing else)
  5. [[nutwo now results in No match found. [[nu two, however, works.

Since I couldn’t reproduce this bug with other notes or in an completely empty vault, I figured this is related to my files. I tried to investigate.

  1. Deleted half of the notes
  2. checked if [[nutwo works. Repeat step 1 until it does.
  3. Bring back deleted notes in half chunks and repeat the binary search-like deletion process until I find the culprit notes.
  4. Vault is now 700 notes, 0 plugins/themes/non-.md files. If I delete the culprit file, [[nutwo works.
  5. If I keep the file, but delete some of the links in properties – [[nutwo works.
  6. Finally I realized that the issue is when I go over 699 notes. If I create an empty 700th file, it breaks the auto-complete too.

I tried creating 700 empty files with a Python script, as well as some with various links, but couldn’t reproduce the bug. This means that the issue may be related to the specific number of links in my files.

I would be happy to share my notes with the developers (they do not contain any sensitive info) if that would help to find the bug.

Did you follow the troubleshooting guide? [Y/N]

Y

Expected result

Auto-complete link search should find the note name.

Actual result

Auto-complete link search returns No match found.

Environment

SYSTEM INFO:
Obsidian version: v1.6.5
Installer version: v1.6.5
Operating system: Darwin Kernel Version 23.3.0: Wed Dec 20 21:33:31 PST 2023; root:xnu-10002.81.5~7/RELEASE_ARM64_T8112 23.3.0
Login status: logged in
Catalyst license: insider
Insider build toggle: on
Live preview: on
Base theme: adapt to system
Community theme: none
Snippets enabled: 0
Restricted mode: on

RECOMMENDATIONS:
none


Additional information

My main vault contains ~4370 notes, with <5 non-md files.

Can you zip your vault and dm a link to it to me?

Thanks, I did some tests. This is something specific to link suggestion (not quick switcher where fuzzy search works fine) and only happens if you have more than 700 notes. We will look into it.

1 Like

Ok, we did some investigation.
There is nothing wrong. You have a large number of links to non-existing files in your notes.
The total number in searchable items is 29K >10K.