Frontmatter display has changed in 1.1.0

Steps to reproduce

In the editor settings, set “Show Frontmatter” off. Look at a any note with frontmatter.

Expected result

I expect to not see the frontmatter. However, the entire frontmatter is displayed. In the previous (1.0.3) version, the only thing displayed was the tags. I’m not sure why even that was displayed if frontmatter is turned off. What is expected behavior here?

Regardless, the display is different between 1.0.3 and 1.1.0.

Actual result

In the previous version, only the tags would be displayed.


  • Operating system:

I’m running 1.1.0 on Windows 11 (latest) with minimal theme (I tried the default theme and the display is the same).

  • Debug info:

Additional information


post a screen recording of this happening in the sandbox vault.

If you mean in reader (not editor), that is not a bug.
More changes will come to editor as well.

This is marked as “Solution”, but I respectfully disagree. The Reader view is now polluted with the word “Metadata” and a horizontal rule atop all pages, despite “Show frontmatter” being disabled.

If it’s a change then fair enough, but is there an option to really disable front matter and not show the “Metadata” stuff? Thanks.

PS The folding mechanism is also a little clunky - if you fold the Metadata in Reader, then it also folds in Editor view. So it’s the worst of both worlds (for me at least!). Keep the folding separate in each environment, please


@OGRobrain makes the point I was trying to make. If I turn off displaying front matter, then I’m not sure why I should get anything up there.

I also didn’t realize that you could click on the “Metadata” and have it fold up. I guess that makes it better, but still seems to miss the point of turning off front matter.


I could not agree more …

Why is there a setting to get frontmatter out of the way in the reader view, if it is shown anyway?

Displaying frontmatter in the reader view or not should be a conscious decision, depending how clean or ‘Zen’ you want it to be. Folding it away is NOT the solution.


I use the following CSS to hide the frontmatter in reading mode:


.markdown-preview-view .frontmatter-container {
    display: none;

Let me be a bit more specific that toggle is about showing the frontmatter as codeblock in reader. That will be deprecated in a fugure release.
Whether there should be a toggle for this new frontmatter view is still up in the air.


I certainly don’t have a ton of YAML fields in my frontmatter, but I do have some on every one of my 3,000 daily notes. When I have Page Preview enabled, this new presentation of front matter obscures the actual contents of every one of those notes, such that I have to scroll each one and/or manually collapse the Metadata header for as many notes as I would like to read unobscured.

I’m glad the decision to add or remove a toggle for front matter in Reader view is up in the air, because I can’t imagine I’m alone in having a lot of Daily Notes (or notes in general) and enjoying how easy Obsidian has made it thus far to quickly and easily preview them using the core Page Preview plugin.

1 Like

I don’t see the metadata in pop-up page preview. does it happen in the sandbox vault?

If it helps, you can have notes and newly-created notes automatically fold up the YAML to hide it. This collapsed/folded section also persists when you switch to reading mode.

All my notes auto-fold when I create them, so I didn’t even notice this 1.1.0 change. Here’s the steps to set that up:

1 Like

i agree that it is annoying.

1 Like

An alternative to Alan’s solution, with the following snippet you can completely hide YAML using a hotkey.

Copy the below CSS into the snippets folder. With the plugin Snippet commands, map the new hide YAML snippet to a hotkey, such asALT + x, to hide/show YAML in preview and reading mode.

/* ====== Hide YAML ========
/* Reading Mode  */
.frontmatter-container {
    display: none;

/* Live Preview  */
.is-live-preview .cm-hmd-frontmatter {
    display: none;
1 Like

One final comment and then I’m going to leave it since I find it mostly an annoyance though it does affect the speed with which you can view notes.

There are two ways to specify properties in a note.

  1. in the frontmatter
  2. using double colons in the body of the note.

Why do we need both? My answer is that I put things in frontmatter that I don’t want to see if I’m just looking at the note. I keep the URL for any article that I have as a note so I can get back to the original if I need. I don’t need to see it when I’m reading the article. Similarly, I have the author(s) in the frontmatter. That’s useful for dataview queries, but I don’t need it to be displayed. It’s usually in the article anyway.

There are times when I might want to know about things like tags (#state/unfinished or #state/needclarification). I might want to see that anytime I’m in the article. I’m sure there are other examples of non-tag information that people use.

With frontmatter turned off, I have a choice between this (reading view)
or this (edit view)

They are basically the same view, just ones editable and ones not.

With show frontmatter on I get (reading)

or this (editor mode)

The read version shows the metadata twice and the only thing you can do is copy it (you can’t edit it in read mode – which I agree with).

I’m fine with the metadata being displayed and editable in edit mode regardless of whether frontmatter display is turned off or on. However, if I’m in read mode and turned off frontmatter display, then I don’t want to the frontmatter (metadata). As a compromise you could at least have it default to be folded up (thought that is not my preferred solution).

the other option is to change the name “show frontmatter” to something which indicates what it really does, though I’m not quite sure how you explain the current behavior.

I now will get back to playing with canvas. It has some amazing functionality. Getting the lines to draw correctly was, I’m sure, non-trivial. However, there are some bad usability bugs that need to be address. But, that’s the subject for a different thread.


this was adjusted in 1.1.3

1 Like

Happy! Zen reestablished.

Looks good in 1.1.3 Thanks

It still looks really bad in 1.1.3 for me, p-p-please hide these :slight_smile:

Have you disabled the “Show frontmatter” option? In 1.1.3 this works how we wanted it to in the first place, more or less. I’m using the Minimal theme, 1.1.3.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.